ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

catkin_make fails with "Invalid package manifest"

asked 2017-04-17 16:56:27 -0500

alexe gravatar image

updated 2017-04-17 17:25:07 -0500

Hey everybody,

I'm trying to create a catkin workspace, but keep getting the error below when running catkin_make. I run ROS Kinetic on Ubuntu 16.04 and I use a virtual pyton 2.7 conda environment using Anaconda. This is the error I keep getting (the full output is below):

 catkin_pkg.package.InvalidPackage: Invalid package manifest "/opt/ros/kinetic/share/catkin/cmake/../package.xml": Error(s) in /opt/ros/kinetic/share/catkin/cmake/../package.xml:
- The manifest must not contain the following tags: depend, build_export_depend, buildtool_export_depend
CMake Error at /opt/ros/kinetic/share/catkin/cmake/safe_execute_process.cmake:11 (message):
  returned error code 1

I am clueless as to what to do. One other question here suggested PIP-installing catkin_pkg, but that does not solve the problem in my case as catkin_pkg was already installed using PIP, so not finding catkin_pkg is not the issue here. Any help much appreciated!

A bit more information:

Installed ROS Kinetic using sudo apt-get install ros-kinetic-desktop-full

Tried creating the workspace exactly following the tutorial here but obviously didn't get past the catkin_make part

Content of /opt/ros/kinetic/share/catkin/cmake/../package.xml:

<?xml version="1.0"?>
<package format="2">
  <description>Low-level build system macros and infrastructure for ROS.</description>
  <maintainer email="">Dirk Thomas</maintainer>

  <url type="website"></url>
  <url type="bugtracker"></url>
  <url type="repository"></url>

  <author>Troy Straszheim</author>
  <author>Morten Kjaergaard</author>
  <author>Brian Gerkey</author>
  <author>Dirk Thomas</author>


  <depend version_gt="0.2.9">python-catkin-pkg</depend>




    <rosdoc config="rosdoc.yaml"/>

Why does package.xml contain the three tags that it is not supposed to contain, depend, build_export_depend, and buildtool_export_depend, and what can I do about that?

And here is the full output after running catkin_pkg:

$ catkin_make
Base path: /home/alex/catkin_ws
Source space: /home/alex/catkin_ws/src
Build space: /home/alex/catkin_ws/build
Devel space: /home/alex/catkin_ws/devel
Install space: /home/alex/catkin_ws/install
Creating symlink "/home/alex/catkin_ws/src/CMakeLists.txt" pointing to "/opt/ros/kinetic/share/catkin/cmake/toplevel.cmake"
#### Running command: "cmake /home/alex/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/alex/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/alex/catkin_ws/install -G Unix Makefiles" in "/home/alex/catkin_ws/build"
-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting ...
edit retag flag offensive close merge delete


Hi, I'm also running anaconda and ROS on my machine and have issues with python versions, did you find a solution to that ?

Cyril Jourdan gravatar image Cyril Jourdan  ( 2017-07-28 03:44:09 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-08-17 06:31:29 -0500

Horse-man gravatar image

updated 2017-08-17 06:32:07 -0500

I had this problem too, because rosdep and rosinstall packages in conda are old.

I solved this by installing them using pip and installing setuptools:

pip install -U rosdep rosinstall_generator wstool rosinstall six vcstools

conda install setuptools
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-04-17 16:56:27 -0500

Seen: 2,684 times

Last updated: Aug 17 '17