Ask Your Question
1

The frontier_exploration demo fails quickly because the robot can't move.

asked 2017-04-11 14:02:03 -0500

renweiros gravatar image

I followed the instructions given at the frontier_exploration wiki page:

http://wiki.ros.org/frontier_explorat...

roslaunch navigation_stage move_base_gmapping_5cm.launch
roslaunch navigation_stage move_base.xml
roslaunch frontier_exploration global_map.launch

After I specified an exploration region in rviz, the robot will start exploring but soon it will stops.

From the rviz and stage, I observed that the robot most of the times got stuck to some obstacle and failed to recover, but sometimes it was in a open space, not close to any obstacle, and still couldn't move.

In the frontier_exploration terminal, I always saw an error message:

[ERROR] [1491936923.242211778, 124.600000000]: Failed to move

In the move_base terminal, I saw a related error message when the robot got stuck:

[ERROR] [1491936126.596561945, 221.100000000]: Aborting because a valid plan could not be found. Even after executing all recovery behaviors

Has anyone else encounter a similar issue? Do I need to change some configurations/parameters of move_base and exploration_frontier? Any suggestion or help will be highly appreciated.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-04-14 13:50:57 -0500

renweiros gravatar image

I found one possible cause for this issue. The footprint config in navigation_stage/move_base_config/costmap_common_params.yaml doesn't match the sample config in frontier_exploration/launch/global_map.launch.

The footprint config in costmap_common_params.yaml:

#The footprint of the robot and associated padding
footprint: [[-0.325, -0.325], [-0.325, 0.325], [0.325, 0.325], [0.46, 0.0], [0.325, -0.325]]
footprint_padding: 0.01

The footprint config in global_map.launch:

footprint: [[0.1, 0.0], [0.0, 0.1], [-0.1, 0.0], [0.0, -0.1]]
robot_radius: 0.10

I tried changing the one in global_map.launch to match the one in costmap_common_params.yaml and started getting better results, i.e., the exploration won't fail quickly. But the exploration will often fail because the robot can't move, especially when it tries exploring a relatively large unknown area. Does anyone have any suggestion? Many thanks in advance.

edit flag offensive delete link more
0

answered 2017-05-25 13:21:13 -0500

paulbovbel gravatar image

updated 2017-05-25 14:24:26 -0500

I wouldn't consider the sample launch files provided in the frontier_exploration package to be 'demos'. http://wiki.ros.org/frontier_explorat... suggests to take a look at the linked Husky robot simulation demo.

edit flag offensive delete link more

Comments

Thank you for the pointer. Actually, I have tried the Husky frontier exploration demo given at http://wiki.ros.org/husky_navigation/... . The issue that the robot can't move in a relatively large unknown area occurred less often but sometimes it occurred.

renweiros gravatar image renweiros  ( 2017-05-29 13:29:16 -0500 )edit

Due to the comment length limit, I have to split my response into two comments. To resolve or at least alleviate the issue, I guess that I need to further tune the configurations of frontier exploration.

renweiros gravatar image renweiros  ( 2017-05-29 13:32:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-04-11 14:02:03 -0500

Seen: 501 times

Last updated: May 25 '17