Ask Your Question
0

Can't run roslaunch turtlebot_gazebo

asked 2017-04-06 23:52:27 -0500

UniversityStudent1701 gravatar image

My problem is very similar to this other question: http://answers.ros.org/question/22379... However it didn't seem like a solution was ever found so I thought I'd better ask my own question to get some answers.

I have installed ros indigo, gazebo, roslaunch packages and the gazebo turtlebot packages, using sudo apt-get. I have set up my environment using source /opt/ros/indigo/setup.bash. On the gazebo website I am told to run the turtlebot simulation using: roslaunch turtlebot_gazebo turtlebot_empty_world.launch

When I run that command I get the following error:

[turtlebot_empty_world.launch] is neither a launch file in package [turtlebot_gazebo] nor is [turtlebot_gazebo] a launch file name The traceback for the exception was written to the log file

In the question I have linked above the suggested solution was to instead use the command:

roslaunch turtlebot_gazebo turtlebot_world.launch

Running that command gives me a different error:

while processing /opt/ros/indigo/share/turtlebot_bringup/launch/includes/robot.launch.xml:

while processing /opt/ros/indigo/share/turtlebot_bringup/launch/includes/description.launch.xml:

Invalid tag: Cannot load command parameter [robot_description]: command [/opt/ros/indigo/share/xacro/xacro.py '/opt/ros/indigo/share/turtlebot_description/robots/kobuki_hexagons_asus_xtion_pro.urdf.xacro'] returned with code [1].

Param xml is

The traceback for the exception was written to the log file

I am new to ROS and gazebo and any assistance would be appreciated. I also apologise for not knowing how to properly format my question; if anyone can tell me how to mark the error logs as code sections so that they are more readable I would be grateful.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-04-16 23:36:49 -0500

UniversityStudent1701 gravatar image

Solved the problem by deleting a custom version of python so that the default version would be used instead

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-06 23:52:27 -0500

Seen: 1,411 times

Last updated: Apr 16 '17