Ask Your Question
0

Which version of ROS is needed?

asked 2017-03-16 02:20:08 -0500

https://github.com/stereolabs/zed-ros...

https://github.com/MobileRobotics-Ula...

The first package specifies Ubuntu 16.04 and ROS Kinetic. The second specifies ROS Hydro or Indigo. (and Ubuntu 14.04)

Does this mean it's impossible to use them together?

In other words: I was hoping to use Husky-trainer (on a different machine, similar to the Husky) with the ZED stereo camera (and no laser) but I see ZED's latest ROS packages specify Ubuntu 16.04 and ROS Kinetic. It seems ROS Indigo wants Ubuntu 14.04. I am using the NVIDIA Jetson TX1.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-16 06:50:19 -0500

Airuno2L gravatar image

I've never used the Zed wrapper but looking at the github page and going to the v1.0.0 tag, it looks like version 1.0.0 works with Indigo (it's mentioned in the README.md).

I know that the Husky doesn't have support yet for Kinetic from this question here. So I think your best option is to install Indigo and try that v1.0.0 of the Zed wrapper. Even if Clearpath did finish the Husky's support for Kinetic soon, who knows if MobileRobotics-Ulaval will update husky-trainer.

edit flag offensive delete link more

Comments

Thanks for this! Plug-and-Play these things are not, yet!

Rodolfo8 gravatar image Rodolfo8  ( 2017-03-16 13:27:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-03-16 02:20:08 -0500

Seen: 84 times

Last updated: Mar 16 '17