Ask Your Question
2

How to install husky-simulator in kinetic ?

asked 2017-03-12 03:34:35 -0500

danhilu gravatar image

Dear community,

I'm new with ros. After having installed ROS kinetic in a blank Ubuntu 16.04 VM (everything very smooth, unbelievable quality of the ROS wiki), I want to try husky-simulator tutorial, as proposed in http://wiki.ros.org/husky_gazebo/Tuto...

First step in tutorial is

sudo apt-get install ros-indigo-husky-simulator

I get error

E: Unable to locate package ros-indigo-husky-simulator

I understand the package has been created for ROS "indigo" release and since I'm using kinetic it won't work.

Would there be a way to get it working? Alternatively I may need to replace "kinetic" by "indigo" but I feel it does not scale.

Thank you in advance, Daniel.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
6

answered 2018-02-01 15:57:09 -0500

Alaa Hesham gravatar image

updated 2018-02-01 16:50:06 -0500

jayess gravatar image

Credits go to eng/ Esraa Magdy To install husky on ros kinetic this manuipulation has to be performed

$ cd ~/catkin_ws/src   
***%  comment your catkin workspace name here is mine is (catkin_ws)*** 
$ git clone https://github.com/husky/husky.git
$ git clone https://github.com/husky/husky_simulator.git
$ git clone https://github.com/husky/husky_desktop.git

$ cd ..

$ catkin_make
$ sudo apt-get install ros-kinetic-gazebo-ros-pkgs ros-kinetic-gazebo-ros-control
$ sudo apt-get install ros-kinetic-multimaster-launch
$ sudo apt-get install ros-kinetic-lms1xx
$ rosdep install --from-path src --ignore-src  
$ catkin_make 
$ source devel/setup.bash

Now, it's all set up.

2-set the environment variable HUSKY_GAZEBO_DESCRIPTION

$ export HUSKY_URDF_EXTRAS=$(rospack find husky_description)/urdf/empty.urdf

3-Run the simulation environment :

$ roslaunch husky_gazebo husky_empty_world.launch

or

$ roslaunch husky_gazebo husky_playpen.launch
edit flag offensive delete link more

Comments

Thanks for your answer! After installing the packages, the rosdep instruction gives me the following error: ERROR: Rosdep experienced an error: Multiple packages found with the same name "husky_gazebo" and has the packages that are the same in the folders. Does that mean that I can keep only one?

kosmastsk gravatar image kosmastsk  ( 2018-08-06 08:16:33 -0500 )edit
1

answered 2017-03-12 10:51:55 -0500

danhilu gravatar image

updated 2017-03-12 11:10:20 -0500

According to previous question

http://answers.ros.org/question/25364...

kinetic release for the Husky is being worked on. Consequently there may be no obvious answer to my question. I'm now installing ROS Indigo on an Ubuntu 14.04 VM. Everything works fine, Husky is running.

edit flag offensive delete link more
0

answered 2018-11-03 15:33:57 -0500

Sparkle Eyes gravatar image

After some hours search, this answer is what I find for now :https://github.com/husky/husky/issues/66

Basically, it seems we can install husky from the ros-shadow-fixed directory. Will update on whether it works for Ubuntu 16.4 and ROS kinetic

edit flag offensive delete link more

Comments

Jus come back to update: my previous failure to install husky for kinetic with apt-get is resolved after I changed a ubuntu installation. I previously run ubuntu 16.04 in virtualbox. Now I run it on a new computer and everything works fine.

Sparkle Eyes gravatar image Sparkle Eyes  ( 2018-11-05 09:29:05 -0500 )edit
0

answered 2018-11-26 07:17:46 -0500

Everyone, I worked through the issues and I can run waypoint_nav under ROS Kinetic. Here is my public repository at github: https://github.com/jeffreylutz/waypoi... Also, I have waypoint_nav running under Docker. See the Dockerfile and the scripts for building and running it.

Regards, jeff at lutz.ws

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-12 03:34:35 -0500

Seen: 9,048 times

Last updated: Feb 01 '18