Trouble with ROS ZED wrapper [closed]

asked 2017-02-23 08:17:38 -0500

Meccanoid gravatar image


I am trying to get the ZED wrapper working for my project. I manage to build it succesfully, but when i run
roslaunch zed_wrapper zed.launch

i get the following: "ERROR: cannot launch node of type [zed_wrapper/zed_wrapper_node]: can't locate node [zed_wrapper_node] in package [zed_wrapper]"

I've followed the guide on . I have tried to delete the entire workspace and do it from scratch, but that didn't help.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-11-26 17:18:36.523723


Have you sourced the correct setup.bash (ie: the one from the devel directory of your workspace) before trying to use rosrun or roslaunch?

gvdhoorn gravatar image gvdhoorn  ( 2017-02-23 11:34:16 -0500 )edit

Yes, but it didn't fix the problem

Meccanoid gravatar image Meccanoid  ( 2017-02-24 03:02:28 -0500 )edit

What is the output of ls -al /path/to/your/catkin_ws/devel/lib/zed_wrapper?

gvdhoorn gravatar image gvdhoorn  ( 2017-02-24 04:02:52 -0500 )edit

Hello again! I somehow managed to fix this problem, but unfortunately i don't really know. After restarting the terminal a few times it suddenly worked.

Meccanoid gravatar image Meccanoid  ( 2017-02-28 01:41:52 -0500 )edit