Ask Your Question
1

Docker ROS "unable to communicate with master!"

asked 2017-02-09 13:07:14 -0600

entombedstorm gravatar image

Hi, I have ros indigo running through docker and when i try to run rostopic list on a new terminal with roscore open in another, I get "ERROR: Unable to communicate with master!" I don't really have experience with any of this but both of these terminals are on the same laptop so I'm unsure as to what the problem could be or what to do,

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2017-04-10 22:28:25 -0600

Mabecr gravatar image

I was able to fix this by typing ip addr and noting the ip address of the machine I was using.

After finding the IP, edit the /etc/hosts file with that IP and your hostname, which can be found in the /etc/hostname file.

(I had to add 127.17.0.2 9fc279ddb197 to my hosts file)

edit flag offensive delete link more

Comments

I already have the IP and hostname in my /etc/hosts file but I still have the problem ERROR: Unable to communicate with master

fabbro gravatar image fabbro  ( 2020-07-08 03:39:13 -0600 )edit

Actually I exited from my docker container, logged back in, and it is working now. I have two terminals, on my laptop: ter1 in which the ROS application is running and ter2 in which I can do rostopic list and see all the topics. I have in my /etc/hosts file what @Mabecr suggested.

fabbro gravatar image fabbro  ( 2020-07-08 03:42:30 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-02-09 13:07:14 -0600

Seen: 1,012 times

Last updated: Feb 09 '17