ros-virtual-cam problems on catkin_make. ros.h not found, CMakeLists.txt not a suspect?

asked 2017-02-03 16:26:50 -0500

ateator1 gravatar image

updated 2017-02-03 16:29:37 -0500

As seen here

I had ros-virtual-cam workin right out of the box. Since then, my system broke and I had to format my drive and reinstall. I rebuilt my catkin workspace from scratch and also installed libfreenect2 along with its requirements and some optional requirements (CUDA fixed the video card issues I was having previously! Yay!). My catkin_ws/src currently makes with just the iai_kinect2 package inside it. But, when I download the package from the answers on that link and run my catkin_make, I get the following errors:

 [  6%] Building CXX object ros-virtual-cam/CMakeFiles/stream.dir/src/image_converter.cpp.o
[ 13%] Building CXX object ros-virtual-cam/CMakeFiles/stream.dir/src/stream.cpp.o
[ 20%] Building CXX object ros-virtual-cam/CMakeFiles/stream.dir/src/video_device.cpp.o
[ 40%] Built target kinect2_registration
/home/adam/catkin_ws/src/ros-virtual-cam/src/video_device.cpp:6:21: fatal error: ros/ros.h: No such file or directory
compilation terminated.
ros-virtual-cam/CMakeFiles/stream.dir/build.make:110: recipe for target 'ros-virtual-cam/CMakeFiles/stream.dir/src/video_device.cpp.o' failed
make[2]: *** [ros-virtual-cam/CMakeFiles/stream.dir/src/video_device.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
[ 53%] Built target kinect2_bridge_nodelet
[ 66%] Built target kinect2_bridge
[ 80%] Built target kinect2_calibration
[ 93%] Built target kinect2_viewer
/home/adam/catkin_ws/src/ros-virtual-cam/src/image_converter.cpp:5:33: fatal error: cv_bridge/cv_bridge.h: No such file or directory
compilation terminated.
ros-virtual-cam/CMakeFiles/stream.dir/build.make:62: recipe for target 'ros-virtual-cam/CMakeFiles/stream.dir/src/image_converter.cpp.o' failed
make[2]: *** [ros-virtual-cam/CMakeFiles/stream.dir/src/image_converter.cpp.o] Error 1
/home/adam/catkin_ws/src/ros-virtual-cam/src/stream.cpp:17:45: fatal error: image_transport/image_transport.h: No such file or directory
compilation terminated.
ros-virtual-cam/CMakeFiles/stream.dir/build.make:86: recipe for target 'ros-virtual-cam/CMakeFiles/stream.dir/src/stream.cpp.o' failed
make[2]: *** [ros-virtual-cam/CMakeFiles/stream.dir/src/stream.cpp.o] Error 1
CMakeFiles/Makefile2:2993: recipe for target 'ros-virtual-cam/CMakeFiles/stream.dir/all' failed
make[1]: *** [ros-virtual-cam/CMakeFiles/stream.dir/all] Error 2
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
Invoking "make -j4 -l4" failed

which is weird because this same exact download worked perfectly the first time under essentially the same system before and tried to follow all install instructions meticulously (new-ish Linux user here). Ubuntu 16.04 and ROS Kinetic. I am afraid this problem stems from something deeper than just an incorrect CMakeLists.txt, but don't know enough to investigate. I would appreciate it if you guys could help me work through this so that I can once again use kinect2_bridge and ros-virtual-cam to have a video device on my system. I will remain active on this post until this issue is solved. Thank you all in advance.

PS.. I did not follow any of the instructions on the link to "Setup a workspace:". I already setup my workspace, why would I catkin_init_workspace again?

edit retag flag offensive close merge delete