Ask Your Question
4

[groovy] collada parser source incomplete

asked 2013-01-22 11:21:12 -0500

Claudio gravatar image

updated 2013-01-22 13:47:19 -0500

I'm installing groovy from source.

$ sudo wstool init src -j8 http:/packages.ros.org/web/rosinstall/generate/raw/groovy/robot

$ sudo ./src/catkin/bin/catkin_make_isolated --install --install-space /opt/ros/groovy

Compilation fails at collada_parser because of missing dae.h

Looking at the Fuerte install on my laptop, colladadom includes contain a host of different files missing from the groovy raw.

Copying dae.h prompts for another missing file: dom/domCOLLADA.h.

Now there are two possibilities: either copying the dom folder inside the 1.4 subfolder, or the one inside 1.5. The one in 1.4 causes make to output a three pages long series of errors. The one in 1.5 fails because of a missing namespace 'ColladaDOM150'. Commenting out this line (number 75 of the single source file) compilation proceedes succesfully for this package.

Next is collada_urdf which suffers from the same missing includes and wrong namespace. So I copied both dae and dom the same way I did before, but this time make outputs lots of undefined references to collada functions.

I think this is a bug, but I couldn't find how to submit to the tracker (no ticket link on the package's page).

edit retag flag offensive close merge delete

Comments

KruseT gravatar image KruseT  ( 2013-01-22 11:47:54 -0500 )edit

Thanks, doesn't accept my code.ros.org login though...

Claudio gravatar image Claudio  ( 2013-01-22 12:03:59 -0500 )edit

Try reloading after entering the credentials and waiting a bit. The website is very sluggish at the moment. That's why we're migrating off of it.

tfoote gravatar image tfoote  ( 2013-01-26 13:37:13 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-01-26 10:18:20 -0500

kalectro gravatar image

you will need to install collada-dom separately

$ wget http://sourceforge.net/projects/collada-dom/files/latest/download
$ tar -xf download
$ cd collada-dom-2.4.0
$ cmake . && make install
edit flag offensive delete link more

Comments

thanks, I'll try that on the Panda. I tried on my x64 machines, but I get errors on some zip64 functions.

Claudio gravatar image Claudio  ( 2013-01-29 07:16:32 -0500 )edit
1

for your x64 machine, I would recommend using the prebuilt binaries

kalectro gravatar image kalectro  ( 2013-02-04 06:11:12 -0500 )edit

Installing this from source does not solve the problem. At least, not on my Beagle Board xM. I still get a compilation error with dae.h missing. If I had a copy of dae.h, where would I place it?

Josh Whitley gravatar image Josh Whitley  ( 2013-03-09 18:06:31 -0500 )edit

just copying dae.h will not solve your problem. You need to make sure collada-dom is found by collada_parser. Have a look at this guide on how to install it http://www.ros.org/wiki/groovy/Installation/Linaro/Source

kalectro gravatar image kalectro  ( 2013-03-10 09:38:19 -0500 )edit

if anyone has still dae.h missing errors, try this: https://github.com/ros/robot_model/is...

xaedes gravatar image xaedes  ( 2016-01-02 16:21:54 -0500 )edit
1

answered 2013-04-06 20:11:03 -0500

Nicolaje gravatar image

Hi Claudio,

I was having the same issue and just fixed it.

If, like me, you installed the collada-dom library from sources after catkin failed to build collada_parser, you have to delete your current catkin installation and start over (to remove the CMakeCache that couldn't locate the collada-dom headers the first time, and which doesn't get updated when you re-runn the catkin command).

maybe adding --force-cmake to the catkin command would force CMake to update its cache, I haven't tried it.

edit flag offensive delete link more

Comments

Thanks!

collada gravatar image collada  ( 2013-07-04 14:10:21 -0500 )edit

As you said, --force-cmake works like charm ! No need to delete the cmake installation.

yagamiram gravatar image yagamiram  ( 2015-07-19 17:07:37 -0500 )edit

In anycase,If you dont know where to add --force-cmake (Yes, we exists :) ;) ) in Kinetic installation of rasbian jessie this worked. Thanks..

sudo ./src/catkin/bin/catkin_make_isolated --install --force-cmake -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/kinetic -j2
Imesh gravatar image Imesh  ( 2018-01-19 07:01:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-01-22 11:21:12 -0500

Seen: 1,479 times

Last updated: Apr 06 '13