rqt: Fatal IO error when exporting x window to Windows 10 machine

asked 2017-02-02 09:45:13 -0500

bwolfe gravatar image

I am trying to run rqt on an embedded computer that has no display attached. As such, I use PuTTY on a Windows 10.1 computer to ssh in, with Xming on the Windows machine to display X windows content. I have X11 forwarding set up in PuTTY with all the comensurate xauth settings to allow the remote system to export to my Windows machine. I can run xclock and even rviz without errors. However, when I run rqt, I get "rqt: Fatal IO error: client killed". I've seen previous posts to this forum from many years ago with no definitive answers, so thought it worthwhile to see if there is some new knowledge about how to fix this problem.

Running with rosdistro indigo v1.11.20. Rviz says it's version 1.11.14 compiled against Qt version 4.8.6.

Running rqt -v gives following spew

QtBindingHelper using pyqt
PluginManager._discover() using cached plugin discovery information
RospkgPluginProvider._find_plugins() crawling for plugins of type 'qt_gui'
RospkgPluginProvider._find_plugins() crawling for plugins of type 'qt_gui'
PerspectiveManager.switch_perspective() switching to perspective "Default"
MainWindow.restore_settings()
PluginManager.restore_settings()
PluginManager.restore_settings() loading 1 plugins
RosPyPluginProvider._init_node() initialize ROS node "rqt_gui_py_node_6247"
PluginManager._load_plugin(rqt_joint_trajectory_controller/JointTrajectoryController#1) successful
PluginManager.restore_settings() all missing plugins loaded
PluginHandler.restore_settings()
PluginHandler.emit_restore_settings_completed()
PluginManager.restore_settings() all plugin settings restored
MainWindow.restore_state()
rqt: Fatal IO error: client killed
edit retag flag offensive close merge delete

Comments

Not an answer, but: is there a reason you're using Putty and X11 forwarding specifically? Does just setting DISPLAY=:0 not work for you (with XMing running on the Windows side)?

gvdhoorn gravatar imagegvdhoorn ( 2017-02-02 09:47:44 -0500 )edit

X11 forwarding is just a feature PuTTY provides to set the X11 parameters (through ssh) so I don't have to do it manually on the remote system. PuTTY sets DISPLAY to localhost:10.0. Couldn't get any x windows to work without it.

bwolfe gravatar imagebwolfe ( 2017-02-02 10:27:48 -0500 )edit

O wait, I think I've completely misread your question. I had somehow understood that you were trying to run ROS on WSL on Win10 and that you used Putty with X forwarding to get the GUI side working. Nvm.

gvdhoorn gravatar imagegvdhoorn ( 2017-02-02 10:43:57 -0500 )edit

Heh, actually tried that for developing ROS code, but could never get roscore to run due to networking limitations that can presumably only be fixed by getting early builds through the Windows insider program. Wonder if anybody has gotten ROS working under WSL, but that's a different topic.

bwolfe gravatar imagebwolfe ( 2017-02-02 11:06:53 -0500 )edit

See #q238646. Not completely up-to-date, but with current insider build (15019) basic stuff works, but there are some things to fix.

gvdhoorn gravatar imagegvdhoorn ( 2017-02-02 11:27:20 -0500 )edit