Skeleton Tracking

asked 2017-01-19 07:16:37 -0500

fundamentals gravatar image

updated 2017-01-19 07:35:24 -0500

gvdhoorn gravatar image

I am currently in the process of skeleton tracking using the instructions from this link http://dougsbots.blogspot.co.uk/2012/...

When I try to run the command roslaunch skeleton_markers markers_from_tf.launch, I get the following error below

ERROR: cannot launch node of type [openni_tracker/openni_tracker]: can't locate node [openni_tracker] in package [openni_tracker]

The command keeps running after the error and when I try to finish the instructions the skeleton tracking does not work. If anybody knows how I can fix this problem any help would be appreciated.

edit retag flag offensive close merge delete

Comments

2

The tutorial you link is very old, and refers to ROS Electric. That is 6 releases ago. It is very well possible that the packages don't exist or work anymore on recent versions of ROS. Can you tell us how you installed and setup everything?

gvdhoorn gravatar imagegvdhoorn ( 2017-01-19 07:35:05 -0500 )edit

I installed the openni tracker library by using git clone https://github.com/ros-drivers/openni... . When I wanted to run it I changed to my catkin_ws(workspace) then I used the command source devel/setup.bash then I used the commands from the link I posted. @gvdhoorn

fundamentals gravatar imagefundamentals ( 2017-01-20 06:03:10 -0500 )edit

That could then potentially work. Can you make sure there is a openni_tracker binary under devel/lib?

gvdhoorn gravatar imagegvdhoorn ( 2017-01-20 11:05:16 -0500 )edit