Ask Your Question

Building catkin workspace,failed to process package 'qt_gui_cpp'

asked 2016-12-13 12:12:14 -0600

Tanisha12 gravatar image

Hello, I am trying to build the catkin workspace on fedora 23 . I am following instructions given here Installation/Source-ROS Wiki. Under the section 2.1.3 Building the Catkin Workspace, for the command-

$ ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release

My command line session shows the following :

==> Finished processing package [79 of 228]: 'pluginlib'

==> Processing catkin package: 'qt_gui_cpp' ==> Building with env: '/home/tshrotriya/ros_catkin_ws/install_isolated/' Makefile exists, skipping explicit cmake invocation... ==> make cmake_check_build_system in '/home/tshrotriya/ros_catkin_ws/build_isolated/qt_gui_cpp'

==> make -j4 -l4 in '/home/tshrotriya/ros_catkin_ws/build_isolated/qt_gui_cpp' [ 83%] Built target qt_gui_cpp [ 88%] Running SIP generator for qt_gui_cpp_sip Python bindings...

Traceback (most recent call last):
File "/home/tshrotriya/ros_catkin_ws/install_isolated/share/python_qt_binding/cmake/", line 47, in <module> config = Configuration() File "/home/tshrotriya/ros_catkin_ws/install_isolated/share/python_qt_binding/cmake/", line 16, in __init__ ['qmake', '-query'], env=env, universal_newlines=True) File "/usr/lib64/python2.7/", line 566, in check_output process = Popen(stdout=PIPE, popenargs, kwargs) Fi le "/usr/lib64/python2.7/", line 710, in __init__ errread, errwrite) File "/usr/lib64/python2.7/", line 1335, in _execute_child No such file or directory src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/build.make:89: recipe for target 'sip/qt_gui_cpp_sip/Makefile' failed make[2]: * [sip/qt_gui_cpp_sip/Makefile] Error 1 CMakeFiles/Makefile2:374: recipe for target 'src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all' failed make[1]: ** [src/qt_gui_cpp_sip/CMakeFiles/libqt_gui_cpp_sip.dir/all] Error 2

Makefile:138: recipe for target 'all' failed make: * [all] Error 2 <== Failed to process package 'qt_gui_cpp': Command '['/home/tshrotriya/ros_catkin_ws/install_isolated/', 'make', '-j4', '-l4']' returned non-zero exit status 2 Reproduce this error by running: ==> cd /home/tshrotriya/ros_catkin_ws/build_isolated/qt_gui_cpp && /home/tshrotriya/ros_catkin_ws/install_isolated/ make -j4 -l4

Command failed, exiting.

I am not able to understand the next thing to do, I tried

$ cd /home/tshrotriya/ros_catkin_ws/build_isolated/qt_gui_cpp && /home/tshrotriya/ros_catkin_ws/install_isolated/ make -j4 -l4

But that didn't do much either. Help please.

edit retag flag offensive close merge delete


Did you solved it?

Blind0ne gravatar image Blind0ne  ( 2019-02-09 12:01:14 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-02-09 12:16:18 -0600

Blind0ne gravatar image
sudo apt-get install sip-dev pyqt5-dev python-sip-dev pyqt5-dev-tools
edit flag offensive delete link more


Thanks, it worked.

girayuzun gravatar image girayuzun  ( 2020-02-04 02:33:46 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-12-13 12:10:55 -0600

Seen: 644 times

Last updated: Feb 09 '19