ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

I suspect vim-ros plugin is not working appropriately

asked 2016-12-10 19:08:06 -0500

Randerson gravatar image

updated 2016-12-10 19:08:47 -0500

Hello all. I just installed the vim plugin vim-ros but I fell it is not working or at least not appropriately. Well, after its installation a source file from some ROS package and tried the commands :A, :Roscd and :Rosed and none of them worked. In fact the following message is printed by vim:

E492: Not an editor command: A

So, I would like to know what am I missing to correctly configure the vim-ros plugin.


edit retag flag offensive close merge delete


I would report this on the issue tracker of vim-ros. That will probably lead to quicker resolution of your issues.

gvdhoorn gravatar image gvdhoorn  ( 2016-12-11 03:05:19 -0500 )edit

Could issues/18 be related?

gvdhoorn gravatar image gvdhoorn  ( 2016-12-11 03:06:02 -0500 )edit

thanks!!! I will check it.

Randerson gravatar image Randerson  ( 2016-12-11 10:22:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-12-23 15:50:38 -0500

clyde gravatar image

For completeness, I'll post the answer here.

gvdhoorn was right; it was related to issues/18. The fix is to install vim with Python 2.7 support:

sudo apt-get install vim-nox-py2
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-12-10 19:08:06 -0500

Seen: 531 times

Last updated: Dec 23 '16