Rviz crashing (core dumped) when running with Gazebo

asked 2016-12-01 05:45:04 -0500

McKracken82 gravatar image

Hi to all,

I'm following a tutorial, for which I have to run a launch file that runs Gazebo (with a wold with three robots) and runs also rviz. What happens constantly is that rviz always crashes, while Gazebo keeps running. This happens also if I run rviz from command line with rosrun (while Gazebo is still on), terminating with the message

[ INFO] [1480592319.442365758]: rviz version 1.11.15
[ INFO] [1480592319.442474349]: compiled against Qt version 4.8.6
[ INFO] [1480592319.442517957]: compiled against OGRE version 1.8.1 (Byatis)
[ INFO] [1480592319.648792445]: Stereo is NOT SUPPORTED
[ INFO] [1480592319.648914712]: OpenGl version: 3 (GLSL 1.3).
Segmentation fault (core dumped)

Is it possible that my laptop is not powerful enough?

edit retag flag offensive close merge delete


Are you running this in a virtual machine?

gvdhoorn gravatar image gvdhoorn  ( 2016-12-01 06:35:28 -0500 )edit

No, I'm running everything in a real Ubuntu 14.04. Funny thing is that if I run the same exact launch file on another laptop (definitely less powerful than mine), both gazebo and rviz can live together. I have to imply that there should be other problems on my laptop...

McKracken82 gravatar image McKracken82  ( 2016-12-01 06:51:52 -0500 )edit

What kind of graphics hw do you have in your laptop? Do you have the proper drivers installed? A laptop I have here (9 years old) prints: OpenGl version: 3.3 (GLSL 3.3), so the OpenGl version: 3 (GLSL 1.3) is a bit suspicious (you get that when drivers aren't installed).

gvdhoorn gravatar image gvdhoorn  ( 2016-12-01 07:08:55 -0500 )edit

I have a Nvidia GeForce 640M. The drivers are the standard-default ones that come with ubuntu 14.04 (nouveau). I tried installing the proper ones (nvidia-375), but I just messed up xorg (graphic interface wasn't starting anymore). I rolled back, but yet no gazebo and rviz together working.

McKracken82 gravatar image McKracken82  ( 2016-12-01 10:08:22 -0500 )edit

Well, I think that's your problem. The nouveau ones just aren't up to the task (yet). How did you install the nvidia ones? Via the Additional drivers applet? That should have worked. Running the installer manually isn't really needed on Ubuntu.

gvdhoorn gravatar image gvdhoorn  ( 2016-12-01 10:25:31 -0500 )edit