Ask Your Question
0

Is there a way to prevent the VLP-16 from disconnecting after it starts delivering information? [closed]

asked 2016-11-17 15:03:04 -0600

kparikh gravatar image

When I connect the VLP-16, the connection works fine, but after a few minutes Ubuntu indicates that the connection has been disconnected.

These are the commands I input into the terminal to get a data feed.

sudo ifconfig eth0 up
sudo ip addr add 192.168.1.200 dev eth0 
sudo route add -net 192.168.1.0 netmask 255.255.255.0 dev eth0
roslaunch velodyne_pointcloud VLP16_points.launch  calibration:=/home/user/PUCK_Calibration.yaml

I need the connection to be stable between the laptop and the LIDAR for a very long time. Is there a stable way to establish a connection? Because when it disconnects, I need to rerun those commands to get data from the lidar again.

Am I doing something wrong?

I am using Ubuntu 14.04 LST with ROS Indigo.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by kparikh
close date 2016-11-23 18:41:11.407066

Comments

1

Are you on a wireless network? Or a network with a DHCP server that has a very short lease-time?

gvdhoorn gravatar imagegvdhoorn ( 2016-11-18 00:42:34 -0600 )edit

I am on a wireless network. Do I need to turn off wifi while connected to the LIDAR?

kparikh gravatar imagekparikh ( 2016-11-18 12:07:58 -0600 )edit

No, as your lidar is on a wired connection it should not matter. I was just wondering if frequent disconnects on your wireless might trigger a DHCP release/renew cycle. That could result in loss of routes, leading to what you described.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-18 12:58:02 -0600 )edit

In general though: unless you need your eth0 for something else, why not just configure it with a static IP? No need to fiddle with ip addr and adding routes.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-18 12:59:17 -0600 )edit

I'll give that a shot. I was having trouble before when I wasn't fiddling with the ip addr but I'll see if I can make it work with just a static IP.

I was following this answer.

kparikh gravatar imagekparikh ( 2016-11-18 13:24:57 -0600 )edit

Please just accept your own answer instead of closing the question with just some comments. That will more clearly mark this question as answered. Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-19 05:21:34 -0600 )edit

If you don't mind, could you write the answer out. I don't have enough points to accept my own answer yet. I'll accept yours and close it.

kparikh gravatar imagekparikh ( 2016-11-19 10:56:31 -0600 )edit

I've accepted it for you. Good to hear you got things to work.

gvdhoorn gravatar imagegvdhoorn ( 2016-11-19 12:15:22 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-11-18 16:03:25 -0600

kparikh gravatar image

I checked the wired connection settings and it seems like it was set to Automatic (DHCP). It works now that I set it to manual and input the ip and mask. Thanks.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-11-17 15:03:04 -0600

Seen: 280 times

Last updated: Nov 17 '16