Ask Your Question
0

Turtlebot Computer has OpenCV 3.0 and I don't want it

asked 2016-11-03 20:29:50 -0600

Pototo gravatar image

updated 2016-11-03 20:40:14 -0600

Folks,

I need openCV 2.4 (since I am using indigo). But my turtlebot has 3.0, making conflicts during catkin_make. How do I remove OpenCV 3.0, or at least, how do I built against OpenCV 2.4? OpenCV 3.0 was install locally, so I cannot use sudo apt-get remove.

I found all the libopencv-....so.3.0.0, but I don't know if removing all those libraries will solve the problem

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-04 12:23:04 -0600

Pototo gravatar image

I just removed everything related to OpenCV 3.0 from the /usr/local/ folder, recompiled ROS workspace, and problem solved!!!!!!!!!

edit flag offensive delete link more

Comments

Explicitly specifying version 2 as a requirement to find_package(OpenCV 2 REQUIRED) could also have worked, although I've seen other users still having problems when using that approach.

gvdhoorn gravatar image gvdhoorn  ( 2016-11-05 06:34:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-03 20:29:50 -0600

Seen: 64 times

Last updated: Nov 04 '16