Ask Your Question
0

how to make the map thicker? (gmaping params)

asked 2016-11-03 00:35:36 -0500

updated 2016-11-17 02:46:13 -0500

I'm using the gmapping/slam_gmapping node to create the map using ros_arduino_bridge and neato_laser_driver with those the /odom , /scan, and /tf can be published.

I referred the parameter configuration of rbx1: here and I found that:

  • the map is drawn lightly.
  • there are many emissive lines which is not as the reality and should be get rid of.

Can you guys tell me which parameter of slam_gmapping influences these features?

Thank You Very Much!!

ps: I'm using the ros-indigo and neato_xv11 laser scanner. THX!!

image description

edit retag flag offensive close merge delete

Comments

The map did not get denser even I stay the robot at some position for 1 hour.

sonictl gravatar imagesonictl ( 2016-11-03 00:49:58 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-11-03 02:01:57 -0500

mgruhler gravatar image

The emissive lines typically come from laser scanner max range measurements. Some laser scanners map scan errors to max range as well, which could lead to this problem. I haven't worked with the neato myself, so I cannot tell if this is the problem here.

Also, typically, you don't update the map if you don't move the robot. gmapping has three parameters when to trigger an update:

  1. linearUpdate
  2. angularUpdate
  3. temporalUpdate

If you want to update also why standing still, you should set temporalUpdate to something else then -1.0 (default), which disables temporal updates.

edit flag offensive delete link more

Comments

thx mig! I think this problem may be not as so simple. If the map scan errors caused the emissive lines, there should be some black points appears at the end of the emissive lines, more or less. Neverthless, there is no black poit at all.

sonictl gravatar imagesonictl ( 2016-11-17 02:47:14 -0500 )edit
1

answered 2016-11-17 07:52:31 -0500

I changed the maxRange parameter and it works well. emissive lines doesn't appears.

edit flag offensive delete link more
0

answered 2016-11-17 07:53:17 -0500

updated 2016-11-17 07:54:43 -0500

I changed the maxRange parameter and it works well. And the emissive lines doesn't appears. Thank @mig very much!!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-03 00:35:36 -0500

Seen: 208 times

Last updated: Nov 17 '16