Installing the ros-by-example code

asked 2016-10-31 09:39:42 -0600

Wgege gravatar image

updated 2016-11-01 05:21:41 -0600

NEngelhard gravatar image

I operate the following mistakes according to the book ros by example vol 1 indigo.![image description] I just want to install the ros-by-example code.

root@CC:/home/cc# sh rbx1-prereq.sh

Reading package lists... Done

Building dependency tree

Reading state information... Done

Note, selecting 'ros-indigo-openni2-camera' for regex 'ros-indigo-openni-*'

Note, selecting 'ros-indigo-openni-camera' for regex 'ros-indigo-openni-*'

Note, selecting 'ros-indigo-openni2-launch' for regex 'ros-indigo-openni-*'

Note, selecting 'ros-indigo-openni-launch' for regex 'ros-indigo-openni-*'

Note, selecting 'ros-indigo-openni2-camera' for regex 'ros-indigo-openni2-*'

Note, selecting 'ros-indigo-openni2-launch' for regex 'ros-indigo-openni2-*'

Note, selecting 'ros-indigo-freenect-camera' for regex 'ros-indigo-freenect-*'

Note, selecting 'ros-indigo-freenect-launch' for regex 'ros-indigo-freenect-*'

Note, selecting 'ros-indigo-freenect-stack' for regex 'ros-indigo-freenect-*'

Note, selecting 'ros-indigo-laser-scan-sparsifier' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-assembler' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-tilt-controller-filter' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-pipeline' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-scan-matcher' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-ortho-projector' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-geometry' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-filters' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-scan-splitter' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-filters-jsk-patch' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-proc' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-filtering' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-scan-publisher-tutorial' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-laser-cb-detector' for regex 'ros-indigo-laser-*'

Note, selecting 'ros-indigo-dynamixel-motor' for regex 'ros-indigo-dynamixel-motor-*'

Note, selecting 'ros-indigo-arbotix-msgs' for regex 'ros-indigo-arbotix-*'

Note, selecting 'ros-indigo-arbotix' for regex 'ros-indigo-arbotix-*'

Note, selecting 'ros-indigo-arbotix-sensors' for regex 'ros-indigo-arbotix-*'

Note, selecting 'ros-indigo-arbotix-controllers' for regex 'ros-indigo-arbotix-*'

Note, selecting 'ros-indigo-arbotix-python' for regex 'ros-indigo-arbotix-*'

Note, selecting 'ros-indigo-arbotix-firmware' for regex 'ros-indigo-arbotix-*'

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:

libopencv-dev : Depends: libopencv-core-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-ml-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-imgproc-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-video-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-objdetect-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-highgui-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-calib3d-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-flann-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-features2d-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-legacy-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-contrib-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-ts-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-photo-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-videostab-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-stitching-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-gpu-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-superres-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libopencv-ocl-dev (= 2.4.8+dfsg1-2ubuntu1) but it is not going to be installed

             Depends: libopencv2.4-java (= 2.4.8+dfsg1-2ubuntu1) but it is not going to be installed

             Depends: libopencv2.4-jni (= 2.4.8+dfsg1-2ubuntu1) but it is not going to be installed

             Depends: libcv-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libhighgui-dev (= 2.4.8+dfsg1-2ubuntu1)

             Depends: libcvaux-dev (= 2.4.8+dfsg1-2ubuntu1)

E: Unable to correct problems, you have held broken packages.

ROS's version is indigo,my OS is ubuntu 14.0(Trusty Tahr). Could somebody help me?

edit retag flag offensive close merge delete

Comments

Please edit your question to provide more information. Helpful information would be what OS you're running on as well as what the general state of your system is in relation to having installed packages that might conflict etc. Please review http://wiki.ros.org/Support for good question guildelines.

tfoote gravatar imagetfoote ( 2016-10-31 13:43:05 -0600 )edit