Ask Your Question
0

Reem_sim/ ROS Hydro on ubuntu 16.04

asked 2016-10-12 11:55:23 -0500

r0josh gravatar image

updated 2016-10-14 09:36:53 -0500

My env: Ubuntu 16.04 (Xenial), ROS kinetic.

I need to work with Reem robot simulation. I tried following instructions as per Launching a REEM Gazebo simulation. But got stuck at

$ rosdep install --from-paths src --ignore-src --rosdistro hydro -y

which returned

ERROR the following packages/stacks could not have their rosdep keys resolved to system dependencies
reem_tabletop_grasping: No definition of [object_recognition_msgs] for OS version [xenial]
reem_moveit_config No definition of [moveit_simple_controller_manager] for OS version [xenial]

So how do I get this running. Should I install Ros Hydro? But ROS Hydro ONLY supports Precise, Quantal, and Raring for debian packages, as per Ubuntu install of ROS Hydro.

Should I install Ubuntu Raring for this now? Thank You


Edit: tried $ rosdep install --from-paths src --ignore-src -y

It says,

ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
reem_tabletop_grasping: Cannot locate rosdep definition for [moveit_commander]
reem_bringup: Cannot locate rosdep definition for [play_motion]
reem_object_recognition: Cannot locate rosdep definition for [object_recognition_tabletop]
reem_moveit_config: Cannot locate rosdep definition for [moveit_simple_controller_manager]
edit retag flag offensive close merge delete

Comments

Please check your question after / before posting it. I've had to significantly edit it, as it was completely unreadable before. Using proper formatting will make it easier for other users to help you, which in turn increases your chances of getting good answers.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-12 13:11:03 -0500 )edit

Thank u @gvdhoorm. Sorry for the noobie formatting (I really am a noobie). I didn't understand how to get the 'code' block and a blank line.

r0josh gravatar imager0josh ( 2016-10-12 23:28:31 -0500 )edit

Your latest edit seems to suggest this is a new problem (you're not running 16.04 anymore). I would suggest you open a new question for that to keep things clear for future readers.

Apart from that: do you have ros-hydro-imu-sensor-controller installed? The REEM pkgs may not declare that dep.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-14 03:17:53 -0500 )edit

I was hoping REEM pkgs to handle that. Thanks a lot for the tip.

r0josh gravatar imager0josh ( 2016-10-14 09:35:54 -0500 )edit

The reem pkgs should have that dependency declared, yes, but if they don't, then a rosdep install .. won't pick them up. Perhaps report the issue over at their bug tracker.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-14 11:49:30 -0500 )edit

Also: I just noticed that there is an Indigo version of all of this. That would probably have had a better chance to work on Kinetic than the Hydro version ..

gvdhoorn gravatar imagegvdhoorn ( 2016-10-14 11:49:58 -0500 )edit

I too found indigo version for REEM C robot. Is that gonna work with REEM?

r0josh gravatar imager0josh ( 2016-10-14 12:47:01 -0500 )edit

Probably not. REEM is a different robot from REEM C. I was actually referring to reemc-sim-indigo.rosinstall.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-14 13:25:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-10-12 13:12:30 -0500

gvdhoorn gravatar image

updated 2016-10-13 05:03:29 -0500

I haven't tried it, but you could see whether leaving off the --rosdistro hydro from the rosdep install .. command makes this work.

No guarantees, as the main wiki/Robots/REEM explicitly mentions Hydro as being the target platform.


Edit: MoveIt hasn't been released on Kinetic, so rosdep cannot resolve those two packages. You can see whether things will work if you build it from source.

edit flag offensive delete link more

Comments

Tried that, didn't work. Created a bootable USB with 13.04 and met with "Kernel Panic". Looks like a bad day. Getting 12.04 now.

r0josh gravatar imager0josh ( 2016-10-13 04:48:57 -0500 )edit

"Didn't work" is not really informative. What happened?

gvdhoorn gravatar imagegvdhoorn ( 2016-10-13 05:02:18 -0500 )edit

Thank You for that edit. It seems to be in Beta. I'm skeptical.

r0josh gravatar imager0josh ( 2016-10-13 05:48:11 -0500 )edit
1

(moveit maintainer here): we have multiple ppl building moveit from source on Kinetic and using it daily. There are some rough edges, but the install instructions should work. If they don't, please report to the moveit issue tracker on github.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-13 08:36:26 -0500 )edit
1

Btw: I'd recommend using a workspace underlay for MoveIt. Then overlay your reem workspace on top of that.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-13 08:36:44 -0500 )edit

Could you pls point me to some sort of a guide/tutorial.

r0josh gravatar imager0josh ( 2016-10-13 10:26:02 -0500 )edit

For building MoveIt? See the 'from source' link I posted above.

For overlaying workspaces? See Overlaying with catkin workspaces.

gvdhoorn gravatar imagegvdhoorn ( 2016-10-13 11:06:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-12 11:55:23 -0500

Seen: 879 times

Last updated: Oct 14 '16