Ask Your Question
0

Unable to install Rviz in Indigo

asked 2016-09-15 13:19:10 -0500

Cerin gravatar image

updated 2016-09-16 15:01:35 -0500

Attempting to install Rviz on Ubuntu 14/Indigo results in the error:

$ sudo apt-get install ros-indigo-rviz
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-indigo-rviz : Depends: libgl1-mesa-dev but it is not going to be installed
                   Depends: libglu1-mesa-dev but it is not going to be installed
                   Depends: libqt4-opengl-dev but it is not going to be installed
                   Depends: ros-indigo-resource-retriever but it is not going to be installed
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

All other Indigo packages install just fine. Also, running dpkg --get-selections | grep hold shows no held packages.

What's causing this error? How do I install Rviz on Indigo?

I'm running Ubuntu 14.04.5.

Edit: I get a similar message on Ubuntu 16.04 with Kinetic:

$ sudo apt-get install ros-kinetic-rviz
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-kinetic-rviz : Depends: libgl1-mesa-dev but it is not going to be installed
                    Depends: libglu1-mesa-dev but it is not going to be installed
                    Depends: ros-kinetic-image-geometry but it is not going to be installed
                    Depends: ros-kinetic-python-qt-binding but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The output of dpkg -l | grep libgl1-mesa is:

ii  libgl1-mesa-dri:amd64                       11.2.0-1ubuntu2.2                                           amd64        free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-dri:i386                        11.2.0-1ubuntu2.2                                           i386         free implementation of the OpenGL API -- DRI modules
rc  libgl1-mesa-dri-lts-vivid:amd64             3:13                                                        amd64        Transitional package for libgl1-mesa-dri-lts-vivid
rc  libgl1-mesa-dri-lts-vivid:i386              3:13                                                        i386         Transitional package for libgl1-mesa-dri-lts-vivid
ii  libgl1-mesa-glx:amd64                       11.2.0-1ubuntu2.2                                           amd64        free implementation of the OpenGL API -- GLX runtime
ii  libgl1-mesa-glx:i386                        11.2.0-1ubuntu2.2                                           i386         free implementation of the OpenGL API -- GLX runtime
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-09-16 15:59:37 -0500

Cerin gravatar image

The problem, which wasn't immediately visible from the initial error message, was that the ROS visual packages need libdrm-dev which couldn't be installed because I had used an xorg PPA to install some bleeding edge graphics packages, and those were blocking the installation of some standard libdrm* Ubuntu packages.

I was able to resolve this by running:

sudo aptitude install libdrm-dev

which is able to resolve this by downgrading the libdrm* packages back to the standard Xenial/Trusty packages. After that, the ROS packages installed just fine.

edit flag offensive delete link more
0

answered 2016-09-15 14:56:41 -0500

ahendrix gravatar image

This looks like the dependency issue mentioned in the installation guide: http://wiki.ros.org/indigo/Installati...

You don't say which patch version of Ubuntu 14.04 you're using (14.04.0? 14.04.3? etc), so I can't tell if that actually applies to your or not, but this is probably the same root issue as http://answers.ros.org/question/20282... and http://answers.ros.org/question/20361...

edit flag offensive delete link more

Comments

The solutions listed in the Installation section result in similar errors.

Cerin gravatar imageCerin ( 2016-09-15 15:29:03 -0500 )edit

It seems like you might have different, incompatible versions of the mesa packages installed. Something like dpkg -l | grep libgl1-mesa should show you which variant of the mesa packages you have installed.

ahendrix gravatar imageahendrix ( 2016-09-15 16:54:10 -0500 )edit

I've updated my question to show my mesa packages.

Cerin gravatar imageCerin ( 2016-09-16 15:02:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-15 13:19:10 -0500

Seen: 902 times

Last updated: Sep 16 '16