ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Anyone success run rviz from launch file on Nvidia TX1?

asked 2016-09-13 15:10:47 -0500

Thang Nguyen gravatar image

updated 2016-09-18 00:40:07 -0500

Hi, I am trying to run rviz from launch file and it failed. I can run it manually from terminal but when I put it in launch file it failed. If you can do it please tell me necessary steps to have it run.

Thank you very much.

Edit 1: The reason I think it's TX1 is because if I remove the last line to run rviz the the launch file work normally. I then can run rviz on a separate terminal with no problem.

Launch file:

    <arg name="model" />  
    <param name="robot_description" textfile="$(find mastering_ros_robot_description_pkg)/urdf/pan_tilt.urdf" />  

    <param name="use_gui" value="true"/>
    <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher" />  
    <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher" />
    <node name="rviz" pkg="rviz" type="rviz" args="-d $(find mastering_ros_robot_description_pkg)/urdf.rviz" required="true" /> 


ubuntu@tegra-ubuntu:~/Documents/WorkSpaceMasteringRosRobot$ roslaunch mastering_ros_robot_description_pkg view_demo.launch
... logging to /home/ubuntu/.ros/log/881187c4-797c-11e6-9808-00044b581868/roslaunch-tegra-ubuntu-5259.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://tegra-ubuntu:49364/


 * /robot_description: <?xml version="1....
 * /rosdistro: indigo
 * /rosversion: 1.11.19
 * /use_gui: True

    joint_state_publisher (joint_state_publisher/joint_state_publisher)
    robot_state_publisher (robot_state_publisher/state_publisher)
    rviz (rviz/rviz)


core service [/rosout] found
process[joint_state_publisher-1]: started with pid [5277]
process[robot_state_publisher-2]: started with pid [5278]
process[rviz-3]: started with pid [5279]
================================================================================REQUIRED process [rviz-3] has died!
process has died [pid 5279, exit code -7, cmd /opt/ros/indigo/lib/rviz/rviz -d /home/ubuntu/Documents/WorkSpaceMasteringRosRobot/src/mastering_ros_robot_description_pkg/urdf.rviz __name:=rviz __log:=/home/ubuntu/.ros/log/881187c4-797c-11e6-9808-00044b581868/rviz-3.log].
log file: /home/ubuntu/.ros/log/881187c4-797c-11e6-9808-00044b581868/rviz-3*.log
Initiating shutdown!
[rviz-3] killing on exit
[robot_state_publisher-2] killing on exit
[joint_state_publisher-1] killing on exit
Traceback (most recent call last):
  File "/opt/ros/indigo/lib/joint_state_publisher/joint_state_publisher", line 342, in <module>
  File "/opt/ros/indigo/lib/python2.7/dist-packages/rospy/", line 320, in init_node
    raise rospy.exceptions.ROSInitException("init_node interrupted before it could complete")
rospy.exceptions.ROSInitException: init_node interrupted before it could complete
shutting down processing monitor...
... shutting down processing monitor complete

Edit 2: I tried to install libpcre as follow command

ubuntu@tegra-ubuntu:~/Documents/Packages$ sudo dpkg -i libpcre3_8.35-7.1ubuntu1_armhf.deb 
[sudo] password for ubuntu: 
(Reading database ... 195694 files and directories currently installed.)
Preparing to unpack libpcre3_8.35-7.1ubuntu1_armhf.deb ...
Unpacking libpcre3:armhf (2:8.35-7.1ubuntu1) over (1:8.31-2ubuntu2.3) ...
Setting up libpcre3:armhf (2:8.35-7.1ubuntu1) ...
Processing triggers for man-db ( ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...

Then I got this error

ubuntu@tegra-ubuntu:~/Documents/Packages$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 libpcre3-dev : Depends: libpcre3 (= 1:8.31-2ubuntu2.3) but 2:8.35-7.1ubuntu1 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
ubuntu@tegra-ubuntu ...
edit retag flag offensive close merge delete


This seems less like an issue with the TX1 and is more likely an issue with your launch file or your rviz config. It might be helpful to post your launch file and any errors you get when you run it.

ahendrix gravatar image ahendrix  ( 2016-09-14 00:13:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-09-14 03:20:31 -0500

Check out the comment of dchang0 on this github issue. There are also other suggestion to fix the segfault of rviz, but installing libpcre as suggested has worked for me on TX1 and TK1

edit flag offensive delete link more


@Felix, please take a look at my Edit 2

Thang Nguyen gravatar image Thang Nguyen  ( 2016-09-18 00:40:29 -0500 )edit

I remember having that issue but unfortunately I don't remember how I resolved it. Maybe I just ignored it?

Felix Endres gravatar image Felix Endres  ( 2016-09-21 04:30:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2016-09-13 15:10:47 -0500

Seen: 218 times

Last updated: Sep 18 '16

Related questions