Ask Your Question
0

ResourceNotFound: sbpl on roslaunch

asked 2016-09-02 09:24:37 -0500

non-conventional_stuff gravatar image

From : https://github.com/sbpl/sbpl Installed SBPL at /usr/local

tried :

mudit@mudit:$ export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

`Then:

$ roslaunch sbpl_lattice_planner move_base_sbpl_fake_localization_2.5cm.launch

Shows the following error : ResourceNotFound: sbpl ROS path [0]=/opt/ros/kinetic/share/ros ROS path [1]=/home/mudit/catkin_ws/src ROS path [2]=/opt/ros/kinetic/share ROS path [3]=/opt/ros/kinetic/stacks

edit retag flag offensive close merge delete

Comments

sbpl_lattice_planner probably expects sbpl to be installed in your catkin workspace as a ROS package so that it can find the motion primitives.

ahendrix gravatar image ahendrix  ( 2016-09-02 11:24:33 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-09-02 12:39:43 -0500

non-conventional_stuff gravatar image

The launch file of sbpl lattice planner was searching for sbpl by using find command which was further referencing the motion primitive file. By replacing the find command with absolute path for motion primitve file solved the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-02 09:24:37 -0500

Seen: 744 times

Last updated: Sep 02 '16