Ask Your Question
-1

WARNING: current working directory is not on ROS_PACKAGE_PATH! Please update your ROS_PACKAGE_PATH environment variable.

asked 2016-08-23 14:35:07 -0600

Gabriel1 gravatar image

WARNING: current working directory is not on ROS_PACKAGE_PATH! Please update your ROS_PACKAGE_PATH environment variable.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-08-23 14:52:25 -0600

patrchri gravatar image

updated 2016-08-23 14:57:08 -0600

You need to source your environment before you try to use ROS.

source /opt/ros/YOUR_ROS_DISTRO/setup.bash or .zsh or.sh depending on your shell.

Also, when you try something within your workspace, you need to source the setup files in your devel folder, same logic as above:

source CURRENT_WORKING_WS/devel/setup.bash

See this for more info :

www.ros.org/wiki/ROS/Tutorials/InstallingandConfiguringROSEnvironment

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-08-23 14:35:07 -0600

Seen: 1,986 times

Last updated: Aug 23 '16