Need help for Running the XV-11 Laser Node [closed]

asked 2016-08-23 10:04:38 -0600

IGAPants gravatar image

updated 2016-08-23 13:47:33 -0600

gvdhoorn gravatar image

I've installed ubuntu 12.04 LTS and installed desktop full-install ROS Fuerte using this link http://wiki.ros.org/fuerte/Installati...

when I'm trying this http://wiki.ros.org/xv_11_laser_drive... , from the part 0.1 Install the Driver starting from step 2 and next, everything going wrong.

this is what it shows in terminal

kevin@kevin-msi:~$ rosinstall ~/cwru-ros-pkg /opt/ros/fuerte 'http://www.ros.org/wiki/xv_11_laser_driver/Tutorials/Running%20the%20XV-11%20Node?action=AttachFile&do=get&target=cwru-ros-pkg.rosinstall'
rosinstall operating on /home/kevin/cwru-ros-pkg from specifications in rosinstall files /opt/ros/fuerte, http://www.ros.org/wiki/xv_11_laser_driver/Tutorials/Running%20the%20XV-11%20Node?action=AttachFile&do=get&target=cwru-ros-pkg.rosinstall
(Over-)Writing /home/kevin/cwru-ros-pkg/.rosinstall 
[cwru-ros-pkg] Updating /home/kevin/cwru-ros-pkg/cwru-ros-pkg 
WARNING [vcstools] Command failed: 'git submodule update --init --recursive' run at: '/home/kevin/cwru-ros-pkg/cwru-ros-pkg' 
errcode: 1: 
No submodule mapping found in .gitmodules for path 'catkin/src/cwru_base_hydro/cwru_drivers/hokuyo_node' [/vcstools] 
Exception caught during install: Error processing 'cwru-ros-pkg' : [cwru-ros-pkg] Update Failed of /home/kevin/cwru-ros-pkg/cwru-ros-pkg 

ERROR in config: Error processing 'cwru-ros-pkg' : [cwru-ros-pkg] Update Failed of /home/kevin/cwru-ros-pkg/cwru-ros-pkg

is there anyone who can help me? please T.T

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-30 23:06:18.135459

Comments

Not an answer, and just to get it out of the way: Fuerte has long since been EOL-d, and is no longer actively supported. If at all possible, use a newer ROS release.

gvdhoorn gravatar image gvdhoorn  ( 2016-08-23 13:48:58 -0600 )edit

OK, I'll try with another ROS with newer version, do you have any recommendation? I just follow the steps on a video on youtube [XV-11 Neato Lidar with Arduino] ( https://www.youtube.com/watch?v=zc0Yy... ), but it gone wrong for me. By the way, have you tried to run the XV-11 laser node?

IGAPants gravatar image IGAPants  ( 2016-08-24 11:11:31 -0600 )edit

I have no experience with it, sorry. And I don't know if what you want to do is possible with newer versions of ROS. But since you are on Ubuntu 12.04, you could at least try Hydro. Also EOL, but much more recent. For Indigo you'd need Ubuntu 14.04, which'd mean upgrading.

gvdhoorn gravatar image gvdhoorn  ( 2016-08-24 13:12:50 -0600 )edit

I used this tutorial and had pretty good luck: http://meetjanez.splet.arnes.si/2015/...

billy gravatar image billy  ( 2016-08-26 01:29:07 -0600 )edit

@billy--> i see... so are you using ubuntu 14.04 too? can i know which ROS have you installed? btw, have you installed cwru-ros-pkg environment? thank you so much before ^3^

IGAPants gravatar image IGAPants  ( 2016-08-26 05:37:22 -0600 )edit

Yes, 14.04 and ROS-Jade. Ancient Dell dual core laptop with Intel something-or-other. Never heard of cwru-ros-phg.

billy gravatar image billy  ( 2016-08-26 12:31:34 -0600 )edit