rosserial + Arduino Due

asked 2016-08-10 18:16:43 -0600

roboticsprogrammer gravatar image

I'm new to ROS, so i would appreciate any help with this issue. I'm attempting to use rosserial to send information to the Arduino Due. i followed the tutorials on the ROS Wiki website, but I'm consistently getting the same error after typing the following command: rosrun rosserial_python serial_node.py /dev/ttyACM0

Error: Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

Any solutions? Thanks in advance.

edit retag flag offensive close merge delete

Comments

This seems like a problem with the arduino sketch that you are running on your Due. It would be useful if you could post the contents of that sketch or the name of the example, if you're running one of the examples.

ahendrix gravatar imageahendrix ( 2016-08-10 20:26:54 -0600 )edit

@ahendrix I'm just running the default Blink program from the ROS Wiki website. I don't think it's the Arduino, cause I've also tried with a different one. It's an error in ROS, but I'm not sure what it is

roboticsprogrammer gravatar imageroboticsprogrammer ( 2016-08-10 20:47:45 -0600 )edit

The DUE seems a little weird with the Programming port and the Native port. This ticket seems to suggest that your USB cable should be plugged into the programming port, but I don't have one and haven't tested it.

ahendrix gravatar imageahendrix ( 2016-08-10 23:00:58 -0600 )edit