Install ROSJava/Knowrob on Kinetic

asked 2016-08-09 20:17:47 -0600

toddcpierce gravatar image

updated 2016-08-22 13:49:30 -0600

gvdhoorn gravatar image

Hi Helpers,

I have been attempting to install all kinds of packages and most of them fail either because they don´t exist on kinetic or they don´t build from source because I don´t have the rosjava_build_tools to complete the catkin build process (on Ubuntu 16.04).

So, even though I have no reason for java, apparently I need it to build anything else from source.

I have tried to install it but have found no method that works. Any ideas?



============ Update after comments (and reinstallation of kinetic) ===========

Okay, it looks like they got the ros-desktop-base installation finally working for kinetic. In fact, they finally got the installation for roslisp_repl working. So, part of my issue was handled just by waiting. But that still leaves this issue of catkin depending on rosjava and the rosjava_build_tools. I thought it would come along with the desktop install but it didn´t. What is the process I´m using to install rosjava? There is no process available to install from source or otherwise on kinetic on xenial.

todd@ubuntu:~/rosjava$ rosdep install --from-paths src -i -y
ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
rosjava_build_tools: No definition of [ant] for OS version [xenial]

In fact, even the apt-get installation of rosjava indigo doesn´t exist anymore. As I implied before, I don´t see why they even released kinetic if the build system isn´t even functional yet. For the time being, I´m trying to find a person knowledgeable with knowrob to see if I can get around this.

edit retag flag offensive close merge delete


I'm confused: you say you don't 'have any reason for java'. Why would you want to install it then?

Would it an idea to try and troubleshoot why you can't build things from source first?

gvdhoorn gravatar image gvdhoorn  ( 2016-08-13 14:14:55 -0600 )edit

Please edit your question to include the actual error messages when your attempt to install the packages and include enough information about your process for someone to reproduce your problem.

tfoote gravatar image tfoote  ( 2016-08-14 00:46:19 -0600 )edit

@toddpierce what tutorial are you following? Have you tried this one? is that causing you trouble?

jubeira gravatar image jubeira  ( 2017-10-24 10:14:36 -0600 )edit