Arni does not work with mavros

asked 2016-08-07 06:30:19 -0500

Alaa gravatar image

Hello,

I would like to use arni tool in order to monitor some topics published by gazebo simulation. My simulation scenario requires running MAVROS to control UAV in simulation but Whenever I run the simulation first then the arni tool, the arni gets shut down. Also, when i run arni first and then the simulator, the MAVROS shuts down. I am not sure why both arni and MAVROS can't run at same time.

The arni command I'm using only initializes parameters, it doesn't even run a node. The command is as follows: $ roslaunch arni_core init_params.launch ( this command from ros arni tutorials) Note: I used arni to monitor other topics and it worked fine so basically the problem is when running MAVROS and arni. Also, another weird problem faced is that arni doesn't work with roscore, it shuts down when the roscore is running.

Could you help me in finding a solution, and understanding why this problem happens ??

Thanks in advance

edit retag flag offensive close merge delete