Ask Your Question
0

Invoking "make cmake_check_build_system" failed

asked 2016-07-21 13:42:55 -0500

UsmanArif gravatar image

Hi... I am to ROS and i would be posting lots of questions. :) Th thing i am trying to do is that i want to create multiple packages inside single catkin workspace. I created my package "my_first_pkg" inside "catkin_ws/src". It worked fine. Then i tried to add another package in the same "catkin_ws/src" with the name "my_second_pkg" using "catkin_create_pkg". Then i run following command

catkin_make

it gives me following error. Invoking "make cmake_check_build_system" failed

edit retag flag offensive close merge delete

Comments

It sounds like there is more than just one line in this error message; please edit your question to include the full error message.

ahendrix gravatar image ahendrix  ( 2016-07-21 17:03:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-21 21:52:59 -0500

UsmanArif gravatar image

Hi. Thanks for the reply. I found the error. There was problem with the other packages in the same workspace. One of the other package had wrong cmakelist.txt file..

Thanks :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-07-21 13:42:55 -0500

Seen: 511 times

Last updated: Jul 21 '16