MISSING ueye,nodelets and launch packages in JADE ROS

asked 2016-07-07 06:34:29 -0600

jetgnss gravatar image

Hello, I am working on a ROS project to capture ueye camera data for Localisation. [i am very beginner to ROS]

MACHINE I AM USING: Linux guenon 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux

when i run this command

jetgnss@guenon:~/catkin_ws$ source /home/drouin/ros/install_isolated/setup.bash ### SOURCING HAS NO ERROR

" jetgnss@guenon:~/catkin_ws$ roslaunch ueye nodelets.launch pixel_clock:=30 frame_rate:=30 auto_exposure:=true

I am having an error

[nodelets.launch] is neither a launch file in package [ueye] nor is [ueye] a launch file name The traceback for the exception was written to the log file"

Infact, i checked the JADE installed [my colleague worked with it first] and there were several packages not installed.{ueye,nodelets and launch.......maybe more}

My question is: How can i add these missing packages in ROS without installing it from scratch. OR MAYBE THERE IS SOMETHING ELSE i don't know which cause the error.

I found the descriptions of packages in: http://repositories.ros.org/status_pa...

I also followed several comments with the same issue and tried the suggestions but could not resolve my problem. from: http://answers.ros.org/question/14349...

I hope i explained my problem in a clear way. [I am a very beginner to ROS] Thank you.

edit retag flag offensive close merge delete