Ask Your Question
0

Using static transform publisher within rgbdslam

asked 2016-06-27 07:32:31 -0500

FTUB gravatar image

I'm using rgbdslam (with kinect + freenect driver) to process octomaps which are currently somehow rotated round the x-axis and therefore giving me wrong occupancy grid maps when I try to save with map_saver. I tried to fix this with static_transform_publisher but don't know exactly how to use it. As far as I understood, this has to be added to the beginning of my openni/freenect+rgbdslam.launch - file:

<node pkg="tf" type="static_transform_publisher" name="link1_broadcaster" args="x y z yaw pitch roll frame_id child_frame_id period_in_ms"/>

What are the frame_id and child_frame_id?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-06-29 03:07:42 -0500

You would use your own frame_id, e.g. "rotated_map", and the frame_id given in the fixed_frame_name parameter of rgbdslam ("map" by default"). If you want the conventional "map" to be the corrected one, just change the fixed_frame_name parameter in your rgbdslam launchfile.

edit flag offensive delete link more

Comments

We tried the following but didn't succeed: < node pkg="tf" type="static_transform_publisher" name="rotated_map" args="0 0 0 0 0 90 /openni_camera /map 10"/> and in rgbdslam's launch file < param name="fixed_frame_name" value="/rotated_map"/>

Thank you very much in advance

FTUB gravatar imageFTUB ( 2016-09-01 06:21:51 -0500 )edit

I'd try < node pkg="tf" type="static_transform_publisher" name="rotated_map" args="0 0 0 0 0 90 /rotated_map /map 10"/> and in rgbdslam's launch file < param name="fixed_frame_name" value="/map"/>

Felix Endres gravatar imageFelix Endres ( 2016-09-02 03:29:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-06-27 07:32:31 -0500

Seen: 89 times

Last updated: Jun 29 '16