Multi-master Discovery couldnot detect rosmaster

asked 2016-06-27 06:34:27 -0500

xhsio gravatar image

updated 2016-06-27 06:41:02 -0500


xyz@xyzPC:~/Documents/catkin_ws$ export ROS_MASTER_URI=http://localhost:11311

when i tried to run master discovery in two terminals with different port numbers 11311 and 11312, it is not able to detect any ROS master.

xyz@xyzPC:~/Documents/catkin_ws$ rosrun master_discovery_fkie master_discovery
[INFO] [WallTime: 1467026315.227321] ROS Master URI: http://localhost:11311
[INFO] [WallTime: 1467026315.234884] Check the ROS Master[Hz]: 1
[INFO] [WallTime: 1467026315.235084] Heart beat [Hz]: 0.02
[INFO] [WallTime: 1467026315.235235] Active request after [sec]: 60
[INFO] [WallTime: 1467026315.235381] Remove after [sec]: 300
[INFO] [WallTime: 1467026315.235520] Robot hosts: []
[INFO] [WallTime: 1467026315.235651] Approx. mininum avg. network load: 1.36 bytes/s
[INFO] [WallTime: 1467026315.250098] Start RPC-XML Server at ('', 11611)
[INFO] [WallTime: 1467026315.250628] Subscribe to parameter `/roslaunch/uris`
[INFO] [WallTime: 1467026315.253975] Listen for multicast at ('', 11511)

[WARN] [WallTime: 1467026766.807655] MasterMonitor[/rosservice_31693_1467026766656/set_logger_level]: can't get contact information. ROS master responds with: no provider

the output for rosservice call /master_discovery/list_masters is giving nothing..

xyz@xyzPC:~/Documents/catkin_ws$ rosservice call /master_discovery/list_masters
masters: []

Can someone help me??

edit retag flag offensive close merge delete


Another problem is, both master discovery in two terminals are listening for multicast same ports [INFO] [WallTime: 1467087078.068071] Listen for multicast at ('', 11511)

But the RPC-XML server is started at different ports, one at 11611 and one at 11612.. Anyone know how to deal with it?

xhsio gravatar image xhsio  ( 2016-06-27 23:18:28 -0500 )edit

sorry.. I could resolve this issue by setting ROS_IP also along with ROS_MASTER_URI...

xhsio gravatar image xhsio  ( 2016-06-28 00:20:08 -0500 )edit

Could you explain what exactly did you do because I have a same problem and I did set the ROS_IP and ROS_HOSTNAME and ROS_MASTER_URI. Thank you!

KBOT gravatar image KBOT  ( 2017-01-21 07:33:12 -0500 )edit