Installing ROS Indigo on Raspberry pi 3

asked 2016-06-26 20:13:30 -0600

I believe I have successfully installed ROS indigo on my Raspberry pi 3 following the installation here .

When I run roscore it works fine

When I run rostopic list, I can see the following


Which I think is good. My problem is this. I tried running turtlesim first to make sure all is working fine

I used

$ rosmake turtlesim

and I get the following mistake

pi@raspberrypi:~ $ rosmake turtlesim
[ rosmake ] rosmake starting...                                                                        
[ rosmake ] Packages requested are: ['turtlesim']                                                      
[ rosmake ] Logging to directory /home/pi/.ros/rosmake/rosmake_output-20160627-004752                  
[ rosmake ] Expanded args ['turtlesim'] to:
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['turtlesim']       
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names. 

After that, I tried running catkin_make to install a package I had just downloaded and I a getting the following error

  sphero_ros/sphero_node/CMakeLists.txt:4 (find_package)

-- Could not find the required component 'dynamic_reconfigure'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /home/pi/ros_catkin_ws/devel/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by
  "dynamic_reconfigure" with any of the following names:


  Add the installation prefix of "dynamic_reconfigure" to CMAKE_PREFIX_PATH
  or set "dynamic_reconfigure_DIR" to a directory containing one of the above
  files.  If "dynamic_reconfigure" provides a separate development package or
  SDK, be sure it has been installed.
Call Stack (most recent call first):
  sphero_ros/sphero_node/CMakeLists.txt:4 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/pi/ros_catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/pi/ros_catkin_ws/build/CMakeFiles/CMakeError.log".

Can anybody help me see what is wrong in my installation?

edit retag flag offensive close merge delete