Ask Your Question
2

pan_tilt_port: No motors found + Dynamixel MX-64AR [closed]

asked 2016-06-02 07:23:14 -0500

MahsaP gravatar image

Hello,

I have attached a dynamixel motor MX-64AR via USB to my laptop. The distro of my ROS is indigo running of Ubuntu 14.04. I looked into other answers, but I couldn't solve my problem. When I run the following launch file:

<launch>
    <node name="dynamixel_manager" pkg="dynamixel_controllers" type="controller_manager.py" required="true" output="screen">
        <rosparam>
            namespace: dxl_manager
            serial_ports:
                pan_tilt_port:
                    port_name: "/dev/ttyUSB0"
                    baud_rate: 8000
                    min_motor_id: 1
                    max_motor_id: 4
                    update_rate: 20
        </rosparam>
    </node>
</launch>

I get the following output in the terminal:

SUMMARY
========

PARAMETERS
 * /dynamixel_manager/namespace: dxl_manager
 * /dynamixel_manager/serial_ports/pan_tilt_port/baud_rate: 8000
 * /dynamixel_manager/serial_ports/pan_tilt_port/max_motor_id: 4
 * /dynamixel_manager/serial_ports/pan_tilt_port/min_motor_id: 1
 * /dynamixel_manager/serial_ports/pan_tilt_port/port_name: /dev/ttyUSB0
 * /dynamixel_manager/serial_ports/pan_tilt_port/update_rate: 20
 * /rosdistro: indigo
 * /rosversion: 1.11.19

NODES
  /
    dynamixel_manager (dynamixel_controllers/controller_manager.py)

auto-starting new master
process[master]: started with pid [4794]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 86c272d8-28ba-11e6-817c-e09467568303
process[dynamixel_manager-2]: started with pid [4813]
/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py:92: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.motor_states_pub = rospy.Publisher('motor_states/%s' % self.port_namespace, MotorStateList)
/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py:93: SyntaxWarning: The publisher should be created with an explicit keyword argument 'queue_size'. Please see http://wiki.ros.org/rospy/Overview/Publishers%20and%20Subscribers for more information.
  self.diagnostics_pub = rospy.Publisher('/diagnostics', DiagnosticArray)
[INFO] [WallTime: 1464869228.261456] pan_tilt_port: Pinging motor IDs 1 through 4...
[FATAL] [WallTime: 1464869228.598303] pan_tilt_port: No motors found.
================================================================================REQUIRED process [dynamixel_manager-2] has died!
process has died [pid 4813, exit code 1, cmd /opt/ros/indigo/lib/dynamixel_controllers/controller_manager.py __name:=dynamixel_manager __log:=/home/mahsa/.ros/log/86c272d8-28ba-11e6-817c-e09467568303/dynamixel_manager-2.log].
log file: /home/mahsa/.ros/log/86c272d8-28ba-11e6-817c-e09467568303/dynamixel_manager-2*.log
Initiating shutdown!
================================================================================
[dynamixel_manager-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

Also I did : dmesg | grep tty and got:

[    0.000000] console [tty0] enabled
[  161.384192] usb 1-3: FTDI USB Serial Device converter now attached to ttyUSB0

Can anyone help me to solve the problem. Do I need to add more information in the launch file?

Thank you.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by MahsaP
close date 2016-08-19 09:05:29.736821

Comments

8000 is a really strange nr for a baud rate. Are you sure that is correct?

gvdhoorn gravatar imagegvdhoorn ( 2016-06-02 13:00:37 -0500 )edit

@gvdhoorn I looked into this link for setting the baud rate. Isn't it correct?

MahsaP gravatar imageMahsaP ( 2016-06-02 13:33:56 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-06-02 14:08:35 -0500

gvdhoorn gravatar image

The Dynamixel may support a baud rate of 8000, but that doesn't mean your FTDI converter supports it. That would be something to check. Perhaps see if 9600 works better, but it probably depends on what the Dynamixel is configured for.

edit flag offensive delete link more

Comments

@gvdhoorn Thanks for pointing out baud rate. I checked the manual again. I solved this baud rate issue.

MahsaP gravatar imageMahsaP ( 2016-06-03 03:18:01 -0500 )edit

I have this problem which cost me many days of effort without getting solution, please check it here what is the buad rate for dynamixel motor AX-12A

Abdu gravatar imageAbdu ( 2017-09-27 09:33:55 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2016-06-02 07:23:14 -0500

Seen: 456 times

Last updated: Jun 02 '16