Ask Your Question
0

ROS cannot find any package in new workspace

asked 2016-05-27 18:49:32 -0500

ras_cal gravatar image

updated 2016-05-30 16:38:00 -0500

I have two workspaces ws_A and ws_B with same packages. ws_A is the original and ws_B is a copy. I have gone through the catkin and overlaying tutorials with no avail. I have modified ROS_PACKAGE_PATH, done $ workspace_init, $ catkin_make on ws_B successfully, opened new terminals and done $ source ~/ws_B/devel/setup.bash. Regardless, a roscd package always sends me to the original ws_A folder. I've looked at other accepted answers and tried source /opt/ros/indigo/setup.bash first with no luck. It simply doesn't see ws_B. Using ROS Indigo and Ubuntu 14.04 Any help would be appreciated, in particular the exact steps required to see ws_B.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-06-01 15:10:52 -0500

ras_cal gravatar image

Was able to solve by following the steps here http://answers.ros.org/question/20320... The key was deleting the ws_A build and devel folders. also insured that roscore wasn't running - not sure if that mattered or not.

edit flag offensive delete link more
0

answered 2016-05-31 10:25:58 -0500

Have you tried deleting ws_A's devel folder?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-05-27 18:49:32 -0500

Seen: 1,074 times

Last updated: Jun 01 '16