Ask Your Question
0

soem make all error

asked 2016-05-14 05:25:54 -0500

Balaji gravatar image

I have installed soem from this respiratory https://github.com/smits/soem .

When I run make all, It is showing error like this

--- Entering /home/coe/catkin_ws/src/soem/osal

--- Entering /home/coe/catkin_ws/src/soem/osal/linux

--- Create library libosal.a

--- Leaving /home/coe/catkin_ws/src/soem/osal/linux

--- Leaving /home/coe/catkin_ws/src/soem/osal

--- Entering /home/coe/catkin_ws/src/soem/oshw

--- Entering /home/coe/catkin_ws/src/soem/oshw/linux

--- Create library liboshw.a --- Leaving /home/coe/catkin_ws/src/soem/oshw/linux

--- Leaving /home/coe/catkin_ws/src/soem/oshw

--- Entering /home/coe/catkin_ws/src/soem/soem

make[1]: * No rule to make target simple_test.o', needed bysimple_test'. Stop.

make: * [soem] Error 2

edit retag flag offensive close merge delete

Comments

Have you tried building with catkin_make instead of make? It looks like the build system for that package was converted to cmake, but the instructions weren't updated.

ahendrix gravatar image ahendrix  ( 2016-05-14 05:32:22 -0500 )edit

I placed that in the orocos folder. I build it with catkin_make_isolated --install. Now it is running nicely. How to run soem to scan slave devices?. The instruction in Internet is not working. How can i get tutorial for this.

Balaji gravatar image Balaji  ( 2016-05-16 22:43:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-08 06:29:07 -0500

piyu23srma gravatar image

If you can get through this link it will get into any error. https://github.com/OpenEtherCATsociet...

and finally you will need ros integrated soem. Here is the link for that : https://github.com/gt-ros-pkg/etherca...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-14 05:25:54 -0500

Seen: 310 times

Last updated: Nov 08 '16