Orocos loadComponent failed

asked 2018-10-17 03:52:42 -0600

schwarzp93 gravatar image

updated 2018-10-17 08:17:11 -0600

gvdhoorn gravatar image

Hi Guys :)

I tried to follow this tutorial ( http://wiki.ros.org/Industrial/Tutori... ) to set up a communication between EtherCAT and ROS Kinetic.

When I run the test.ops script, I get the following errors:

0.147 [ ERROR  ][loadComponent] Unable to create Orocos Component 'soem_master::SoemMasterComponent': unknown component type.
0.148 [ ERROR  ][ScriptingService] /home/faps/ws/underlay/src/rtt_soem-master/soem_master/test.ops :Parse error at line 3: Service or Task "Deployer" has no Peer or Service Master (or Deployer was not found at all).
   Switched to : Deployer

Can somebody tell me, what's the problem here? I'm fairly new to the world of orocos and don't really understand what to do...

Thanks in advance! Regards, Philipp

edit retag flag offensive close merge delete

Comments

That is a fairly old tutorial (notice the last date it was edited: 2015-12-18) and there is a big chance that OROCOS has evolved and things don't work like that any longer.

As this is also more an OROCOS question, you may have more luck on the OROCOS forums / trackers.

gvdhoorn gravatar imagegvdhoorn ( 2018-10-17 08:18:23 -0600 )edit