Troubleshooting Arduino-controlled Robot

asked 2016-05-01 16:59:23 -0500

Muhammed Alsayadi gravatar image

updated 2016-05-02 13:59:29 -0500


We have quite an involved project using Arduino Mega ADK and Raspberry Pi 2 Model B. We have them both communicating through rosserial.

On the Arduino side, we have a node that is: subscribed to cmd_vel topic publishing to two topics responsible for transmitting laser values (laserRangeTopic for the distance, and laserRangeIntensity for the intensity).

On the Raspberry Pi side, we have configured the nav2d package with the required configuration files and some C++ nodes (for the laserScan, odometry, and tf_broadcaster).

The two issues that we're having are:

1- Occasional lost sync with device, restarting ...

2- When running roswtf:

ERROR The following nodes should be connected but aren't:

  • /Operator->/Operator (/Operator/local_map/footprint)

Your insights are much appreciated

Update: The roswtf error seems to be an error itself! I ran it no the tutorial3.launch example in the nav2d_tutorial package and it gave the same error even though everything is working there as expected.

edit retag flag offensive close merge delete