ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

rosmake can't find package, but it's in ROS_PACKAGE_PATH

asked 2016-04-27 21:47:32 -0500

jinhwan gravatar image

updated 2016-04-27 21:48:15 -0500

I'm trying to build . I did these commands to add the package to ros workspace.

$ cd ~/rosbuild_ws
$ rosws set apriltag --svn
$ rosws update apriltag
$ source setup.bash

but "$ rosmake apriltag" gives me this error.

[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['apriltag']                                
[ rosmake ] Logging to directory /home/calanchue/.ros/rosmake/rosmake_output-20160428-114104
[ rosmake ] Expanded args ['apriltag'] to:
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['apriltag']
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

Weird thing is that $ROS_PACKAGE_PATH surely contains apriltag package.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-04-27 21:51:26 -0500

ahendrix gravatar image

updated 2016-04-27 21:51:34 -0500

It looks like the package name is april_tags_node. Have you tried that instead?

edit flag offensive delete link more


@ahendrix That was exact my mistake. The problem is solved. thank!

jinhwan gravatar image jinhwan  ( 2016-04-28 02:04:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2016-04-27 21:47:32 -0500

Seen: 193 times

Last updated: Apr 27 '16