Ask Your Question
1

Error in installing ROS indego Ubuntu 14.04 LTS

asked 2016-04-22 14:57:22 -0600

Omarzamany gravatar image

updated 2016-04-23 07:36:47 -0600

gvdhoorn gravatar image

I tried to download ROS indigo more than 3 times and I always receive the same error in the end of the installation : i followed the instructions here:

http://wiki.ros.org/indigo/Installati...

my laptop is 14.04 LTS

N: Ignoring file 'ros-latest.listsudo' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

N: Ignoring file 'ros-latest.listsudo' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

what is the solution ??

edit retag flag offensive close merge delete

Comments

Hi, I got the same problem on Ubuntu 16.04.1. I tried to remove the bad file but useless. Hope someone can solve this.

Tomatofish gravatar imageTomatofish ( 2016-08-25 11:20:57 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2016-04-22 16:31:12 -0600

ahendrix gravatar image

updated 2016-04-22 16:31:29 -0600

It looks like you did not execute step 1.2 correctly. Did the command prompt you for additional input or give you some other sort of strange prompt after you tried to execute: sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list' (Note that the entire command should be entered on a single line)

You should remove the bad file with: sudo rm /etc/apt/sources.list.d/ros-latest.listsudo and execute step 1.2 again.

edit flag offensive delete link more

Comments

when i tried to remove it , i recived this message : sudo rm /etc/apt/sources.list.d/ros-latest.listsudo rm: cannot remove ‘/etc/apt/sources.list.d/ros-latest.listsudo’: No such file or directory

again , nothing happened when i executed the deb packages , dont know why

Omarzamany gravatar imageOmarzamany ( 2016-04-23 04:17:23 -0600 )edit

it asks me to enter the password and then the terminal allows me to enter a new line immediately

Omarzamany gravatar imageOmarzamany ( 2016-04-23 04:42:45 -0600 )edit

It sounds like the bad file has been removed somehow. "execute the deb packages" is not a thing I understand. Please be more specific or list the exact command you're running.

ahendrix gravatar imageahendrix ( 2016-04-24 20:45:47 -0600 )edit

If sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list' works correctly, it should not print anything and should return you to the shell prompt.

ahendrix gravatar imageahendrix ( 2016-04-24 20:46:19 -0600 )edit

You should then continue with the rest of the install steps, starting with step 1.3

ahendrix gravatar imageahendrix ( 2016-04-24 20:46:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2016-04-22 14:57:22 -0600

Seen: 879 times

Last updated: Apr 23 '16