Ask Your Question
0

rospack package not found error

asked 2016-04-21 10:38:03 -0500

siddhesh gravatar image

I created a package in catkin workspace and put a publisher.py node inside the src directory of package which worked fine. Then i added another node subscriber.py node and used catkin_make to build. Now when I try to run any of the nodes or find package i am getting above error. Am I missing any step ?

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-04-21 11:20:11 -0500

gvdhoorn gravatar image

Am I missing any step ?

source /path/to/your/workspace/devel/setup.bash

perhaps?

edit flag offensive delete link more

Comments

Thanks it worked, Do I need to type it before running every node ?

siddhesh gravatar image siddhesh  ( 2016-04-21 11:51:04 -0500 )edit
1

No, not every node. Every bash session (or whatever shell you're running). But if you would want, you could add that line to your .bashrc. You'll get errors if that file doesn't exist though.

gvdhoorn gravatar image gvdhoorn  ( 2016-04-21 13:29:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-21 10:38:03 -0500

Seen: 2,985 times

Last updated: Apr 21 '16