ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Getting package not found error

asked 2014-12-22 08:12:41 -0600

udiboy1209 gravatar image

I recently installed and have started learning about ROS

I was doing the Publisher/Subscriber tutorial given on the website

I created a package using catkin_create_package, built it using catkin_make then tried running rosrun

there it gives Package not found error.

Even rospack gives same error

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-12-22 08:17:51 -0600

gvdhoorn gravatar image

updated 2014-12-22 08:18:43 -0600

Have you remembered to first run source /path/to/your/catkin_ws/devel/setup.bash (Examining the Simple Publisher and Subscriber - Running the Publisher)? Excerpt from that page:

[..] If you are using catkin, make sure you have sourced your workspace's file after calling catkin_make but before trying to use your applications:

edit flag offensive delete link more


Stupid of me! Thanks :)

udiboy1209 gravatar image udiboy1209  ( 2014-12-22 08:26:25 -0600 )edit

Got it.Thanks!

spkadam gravatar image spkadam  ( 2019-08-05 14:01:51 -0600 )edit

Work for me here also. Unable to follow this instruction since I'm following from a book and not the tutorial.

Caloy gravatar image Caloy  ( 2021-04-02 02:30:30 -0600 )edit

answered 2022-06-20 17:49:51 -0600

Tiago_Dev_Br gravatar image

Hey bro! I had this problem too. My error was the different package name.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-12-22 08:12:41 -0600

Seen: 48,809 times

Last updated: Dec 22 '14