Ask Your Question
0

Problem moving the robot using navigation stack

asked 2016-04-21 03:18:58 -0500

b2meer gravatar image

I have setup navigation stack on my robot with all the nodes up and running (move_base, amcl , costmap2d etc.). I am also able to move my robot using teleoperation (keyboard control) and see its motion in Rviz as well. Now, I have created a map using gmapping and loaded it with amcl and when I give 2D NavGoal command from Rviz, the robot does not move. It shows the planned path in Rviz but does not move. In the terminal, it prints 'Got new plan' many times and at the end prints 'Rotate Recovery behavior started'. And after that, nothing happens. Any ideas why the robot is not moving. Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2016-04-21 05:06:13 -0500

Try checking that your robot driver is actually subscribed to the topic that from move_base that sends the Twist commands:

rostopic find geometry_msgs/Twist

... and then

rostopic info <topic name>

on each of the results. There should be a topic that lists move_base as the publisher and your robot driver as the subscriber.

edit flag offensive delete link more

Comments

Move base by default publishes cmd-vel and hence i have setup my robot motor driver to subscribe to cmd-vel topic. But when i run rosnode info cmd-vel, it shows motor driver subscribed to it but move base does not show publishing on cmd-vel. What could be the possible reason ?

b2meer gravatar imageb2meer ( 2016-04-21 08:29:20 -0500 )edit

Perhaps because it's cmd_vel, not cmd-vel? Use the commands above to find the topic that move_base is publishing on.

Martin Günther gravatar imageMartin Günther ( 2016-04-21 09:28:00 -0500 )edit

Actually, its cmd_vel, I wrote my previous comment from mobile and could not find underscore :P, so I had to type cmd-vel. As for move_base, it is publishing several other topics which are basically action published topics like move_base/feedback, move_base/status etc. but not publishing cmd_vel.

b2meer gravatar imageb2meer ( 2016-04-21 09:42:44 -0500 )edit

Then that's why your robot isn't moving! :) I still can't really believe that move_base isn't publishing cmd_vel. Maybe try a rosnode info move_base? Or rqt_graph? Also check the log output for warnings/errors from move_base.

Martin Günther gravatar imageMartin Günther ( 2016-04-21 11:00:51 -0500 )edit

Oh, and you should kill your teleoperation node, sometimes it interferes with move_base.

Martin Günther gravatar imageMartin Günther ( 2016-04-21 11:02:27 -0500 )edit

teleoperation node usually isn't running when i run move_base. It seems as if the robot is constantly stuck in obstacles, this is why recovery behaviors message is also displayed after 'got new plan'. But there are no obstacles in actual and the path shown in Rviz is also clear.

b2meer gravatar imageb2meer ( 2016-04-21 14:20:45 -0500 )edit
1

Oh and I just found out that move_base is publishing messages on navigation_velocity_smoother/raw_cmd_vel but not on cmd_vel

b2meer gravatar imageb2meer ( 2016-04-22 03:00:07 -0500 )edit

hey guys I am new at Ros and I am trying to build an autonomous moving robot.Unfortunately, I am stack in the same error as you posted without any idea what is going wrong. so it will be great if you can give a some help hope you figure it out

Momo gravatar imageMomo ( 2018-06-20 17:11:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-21 03:18:58 -0500

Seen: 1,685 times

Last updated: Apr 21 '16