Ask Your Question
0

rosserial avr doesn't work

asked 2016-04-18 20:17:51 -0500

Jayantha gravatar image

I am trying avr tutorial “Using rosserial with AVR and UART” . What I want is to connect atmega328 to ROS.

It seems it doesn't work.

Atmega328 is on pro mini board with 16 MHz crystal. I tried rosserial Arduino “hello world “ example, it works with Atmega328 on pro mini board. I used FTDI module to connect the rosserial_python serial_node.

I am running ROS Indigo on Ubuntu 14.4.

I have programmed Atmega328 with avrdude. Fuse bits of the Atmega328 were kept as for Arduino.

I have used TTL to USB module to communicate with the rosserial_python serial_node.

I tried at bau rates 38400 and 9600 other than 57600. But it seems I doesn't get synchronized, it doesn't publish at all.

Anybody out there have done something similar to this?

I need help!

And another thing, it is possible verify whether it publishes or not using a terminal program other than ros chatter node?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-09-28 13:54:01 -0500

Talon1205 gravatar image

I have the same issue with the Arduino Pro Mini 5v, and Arduino Nano. When I run the Hello World example some messages get through and some get the "Serial Port read returned short (expected 72 bytes, received 8 instead)." error.

I have found that on the Arduino Mega everything works as it should. You may need to switch to a different Arduino board to get your project to work properly.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-18 20:17:51 -0500

Seen: 199 times

Last updated: Apr 18 '16