rosserial_client avr Tutorial Error

asked 2015-10-15 22:29:23 -0600

jcardenasc93 gravatar image

updated 2015-10-16 03:00:56 -0600

gvdhoorn gravatar image

So this is the problem I want to get that my Atmega16 works as a ros node, for that reason I just followed this tutorial, so when I just run the rosserial_python node mentioned (rosrun rosserial_python serial_node.py /dev/ttyUSB0, that is the correct port in my case) I just get the following error:

[ERROR] [WallTime: 1414579883.599380] Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

I checked my rosserial version installed and match with my ROS version, so I am really confused about that error. My ROS version is Indigo and to be sure about the rosserial version I didn't install the rosserial package form the debian repository I just clone it on my workspace from this repo. I really appreciate any info or answer to solve this.

Thanks to ROS community

edit retag flag offensive close merge delete

Comments

2
rosrun rosserial_python serial_node.py /dev/ttyUSB0

Is this copy/paste? Cause the tutorial tells you to run rosrun rosserial_python serial_node.py _port:=/dev/ttyUSB0 _baud:=115200 (note the _port:=).

gvdhoorn gravatar image gvdhoorn  ( 2015-10-16 03:02:25 -0600 )edit

@gvdhoorn thank's for your attention, yes it is copy paste, anyway I run the node with the "_port:= " and "_baud:" argument but it still without working

jcardenasc93 gravatar image jcardenasc93  ( 2015-10-20 17:53:36 -0600 )edit