Ask Your Question
0

Can't launch libuvc_camera

asked 2016-04-07 09:46:43 -0500

davelkan gravatar image

updated 2016-04-07 09:51:29 -0500

I'm trying to use libuvc_camera to get my usb camera working on a nodelet to reduce CPU usage, but I'm having a lot of trouble. I've brute-forced my way through most of my problems, but now I'm stonewalled. Every time I try to boot the launch file I just get

unsupported descriptor subtype: 3
unsupported descriptor subtype: 3
uvc_get_stream_ctrl_format_size: Invalid mode (-51)

Here's my launch file:

<launch>
  <group ns="camera">
    <node pkg="libuvc_camera" type="camera_node" name="mycam">
      <!-- Parameters used to find the camera -->
      <param name="vendor" value="0x2560"/>
      <param name="product" value="0xc110"/>
      <param name="serial" value="32C0D5400"/> 
      <!-- If the above parameters aren't unique, choose the first match: -->
      <param name="index" value="0"/>

      <!-- Image size and type -->
      <param name="width" value="1280"/>
      <param name="height" value="960"/>
      <!-- choose whichever uncompressed format the camera supports: -->
      <param name="video_mode" value="yuyv"/> <!-- uncompressed/yuyv/nv12/jpeg -->
      <param name="frame_rate" value="10"/>

      <param name="timestamp_method" value="start"/> <!-- start of frame -->
      <param name="camera_info_url" value="file:///home/usr/.ros/camera_info/calibration.txt"/>

      <param name="auto_exposure" value="1"/> <!-- use aperture_priority auto exposure -->
      <param name="auto_white_balance" value="false"/>
    </node>
  </group>
</launch>

And here is the error:

process[camera/mycam-1]: started with pid [22107]
unsupported descriptor subtype: 3
unsupported descriptor subtype: 3
uvc_get_stream_ctrl_format_size: Invalid mode (-51)
[ERROR] [1460040590.634224143]: check video_mode/width/height/frame_rate are available
[camera/mycam-1] process has died [pid 22107, exit code -11, cmd /home/davelkan/locus/babbage/devel/lib/libuvc_camera/camera_node __name:=mycam __log:=/home/davelkan/.ros/log/48edeb92-fc35-11e5-9a05-0862664a2a25/camera-mycam-1.log].
log file: /home/davelkan/.ros/log/48edeb92-fc35-11e5-9a05-0862664a2a25/camera-mycam-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done

And here's the relevant data from lsusb -v

Bus 004 Device 013: ID 2560:c110  
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               3.00
  bDeviceClass          239 Miscellaneous Device
  bDeviceSubClass         2 ?
  bDeviceProtocol         1 Interface Association
  bMaxPacketSize0         9
  idVendor           0x2560 
  idProduct          0xc110 
  bcdDevice            0.00
  iManufacturer           1 e-con Systems
  iProduct                2 e-con's 1MP Monochrome Camera
  iSerial                 3 2C0D5400

FAQS:

  • I have confirmed my device is uvc compliant

  • I have confirmed uvc is correctly installed

  • I have successfully gotten this camera working with usb_cam

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-16 14:26:44 -0500

psammut gravatar image

I'm having the exact same issue with the exact same camera!

I've tried removing everything from the launch file that might conflict and still no luck. The uvc_camera library does work, but doesn't give me access to the exposure settings of this camera.

Did you ever get it working?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-04-07 09:46:43 -0500

Seen: 1,556 times

Last updated: Apr 07 '16