Ask Your Question
2

[Solved] Install ROS Indigo on RaspberyPi3B under Raspbian Jessie

asked 2016-04-05 04:21:03 -0600

MARAUDER gravatar image

updated 2016-04-05 07:24:48 -0600

Hi,

I'm currently installing ROS Indigo on my RP3B under Raspbian Jessie distro. I would like to share with you some hints for those of you attempting to do the same. I am following the instruction from ROS website

  • Take a deep breath, you will need some hours to go trough the installation process (10 hours for me with the Desktop configuration)
  • Make sure you have enough space on you SD card (16 GB is ok, 8 GB is small for further installations on the RP)
  • Until the moment where we build the catkin workspace nothing occurs to me
  • While building the catkin_ws :

-- I faced trouble regarding authorized actions where I was proposed to enter a cd command and then a cmake command. Just adding sudo before the cmake command, running it and running again the whole sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo

-- I faced trouble with roscpp compilation since it ask a lot of swap. I get trough by modifying dphys-swapfile with cd /etc/ && sudo nano dphys-swapfile changing CONF_SWAPSIZE=100 into CONF_SWAPSIZE=1024 AND by adding -j2 option on my building command : sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/indigo -j2 It's slower but works well.

I will let you know for further hints.

edit retag flag offensive close merge delete

Comments

thank you i will try to do it.

Emilien gravatar imageEmilien ( 2016-04-05 07:21:44 -0600 )edit

Thank you, worked fine on my RPI3: succeded to instal Indigo on Jessie

Sylvain gravatar imageSylvain ( 2016-04-08 09:56:06 -0600 )edit
1

Which set of instructions did you follow?

The first says it is for the original Raspberry Pi and recommends the second set of instructions for the Raspberry Pi 3.

jwr gravatar imagejwr ( 2016-05-02 23:02:12 -0600 )edit

The first one, installation from sources. (Ros-comm)

Sylvain gravatar imageSylvain ( 2016-05-03 13:53:54 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-19 12:41:21 -0600

Sauron gravatar image

Hi Marauder, Im trying to install ROS indigo on my RPI 3. I have stuck at the same point for a long time now. It has processed 145/226 packages and there is an internal compiler error while processing roscpp. I did what you have mentioned here but there is still no luck. Could you please help me out here?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-04-05 04:21:03 -0600

Seen: 3,281 times

Last updated: Apr 05 '16