Ask Your Question
1

can any dslr camera be used as webcam in ROS

asked 2016-03-29 23:35:57 -0500

rak gravatar image

updated 2016-03-30 03:21:43 -0500

gvdhoorn gravatar image

i am using a dslr camera as a webcam in ros but i am getting this error

[ERROR] [1459312203.054820640]: Cannot open '/dev/video0': 13, Permission denied.

Please help me

edit retag flag offensive close merge delete

Comments

It's worth making sure /dev/video0 actually exists, and a standard webcam viewer can open and view it.

lucasw gravatar image lucasw  ( 2016-03-30 12:41:41 -0500 )edit

@rak: please do what @lucasw suggests. That is the first thing you should do.

gvdhoorn gravatar image gvdhoorn  ( 2016-04-01 01:25:10 -0500 )edit

@lucasw: i tried this command "ls /dev/vid" after connecting webcam and get this"/dev/video0 " but when i do same with my dslr camera i get this error "ls: cannot access /dev/vid: No such file or directory "

rak gravatar image rak  ( 2016-04-04 23:38:31 -0500 )edit

Does your dslr even support being used as a webcam? Linux may not support it even if it can be used as a webcam in Windows.

lucasw gravatar image lucasw  ( 2016-04-05 07:27:12 -0500 )edit

i have nikon D5300 which is working in ubuntu through darktable software

rak gravatar image rak  ( 2016-04-06 01:48:36 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-03-30 03:03:02 -0500

Mehdi. gravatar image

updated 2016-03-30 03:03:09 -0500

I think you should add your user name to the group "video" in order to be able to access video devices. Try:

sudo usermod -a -G video your_user_name
edit flag offensive delete link more

Comments

Thank you Sir I did what you just said but now i am getting this error [ERROR] [1459400236.521145040]: Cannot identify '/dev/video0': 2, No such file or directory

rak gravatar image rak  ( 2016-03-31 00:02:39 -0500 )edit

it might be that your webcam was added as /dev/video1 . Try running ls -l /dev | grep video to see what video devices are on your system.

Mehdi. gravatar image Mehdi.  ( 2016-04-01 04:06:12 -0500 )edit

I tried ls -l /dev | grep video and it give me this answer: crw-rw---- 1 root video 29, 0 Apr 4 14:49 fb0 crw-rw----+ 1 root video 81, 0 Apr 5 09:45 video0

rak gravatar image rak  ( 2016-04-04 23:24:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-03-29 23:35:57 -0500

Seen: 476 times

Last updated: Mar 30 '16