I cannot configure the ROS environment

asked 2016-03-26 10:52:21 -0600

Knowledge gravatar image

updated 2016-03-26 11:44:29 -0600

gvdhoorn gravatar image

Hi, I am having problem in configuring ROS environment. I have created a package and when i use the rospack find {package name} command it doesn't find it. I sourced the path using

export ROS_PACKAGE_PATH=/home/saad/jade_workspace/sandbox:/opt/ros/jade/share:/opt/ros/jade/stacks

and paste it in the .bashsrc file at the end, still not helpful. Rospack find command doesn't work. As i am using rosbuild please anyone help me out here. My path is not properly set. And please tell me if i am using the ros package command properly.


Edit: I can roscd in my package, but the environment is not set, actually i am unable to know the proper syntax of

export ROS_PACKAGE_PATH=/your/path/to/workspace:$ROS_PACKAGE_PATH

/your/path/to/workspace what does this explain?

Actually i pasted this in my .bashsrc file few days before and the environment was set permanently, but suddenly it didn't work and i deleted this line from my .bashsrc file, now i am trying to configure it again but don't remember how i managed to do that earlier.

i wrote

export ROS_PACKAGE_PATH=/home/saad/sandbox/jade_workspace:/opt/ros/jade/share:/opt/ros/jade/stacks

in my .bashsrc file in the last don't know if it is right.

edit retag flag offensive close merge delete

Comments

Can you roscd to your package? Did you source your .bashrc after adding the export line? In general, it sounds like you're trying to configure your ROS environment in a very unorthodox way.

spmaniato gravatar image spmaniato  ( 2016-03-26 11:12:23 -0600 )edit

I would source the setup.bash file instead of exporting the environment variable (in .bashrc)

spmaniato gravatar image spmaniato  ( 2016-03-26 11:14:43 -0600 )edit
1

@Knowledge: please edit your question if you want to provide us with more information, or use comments. Don't post answers, unless you have an answer. I've merged your answer and comment into your question, but please use the edit button/link next time.

gvdhoorn gravatar image gvdhoorn  ( 2016-03-26 11:46:05 -0600 )edit