Run hector_compressed_map_transport?

asked 2016-03-15 10:08:00 -0600

tony.hegyes gravatar image

Hello everyone,

I've been trying to use the hector_map stack ( http://wiki.ros.org/hector_slam?distr... ) for generating an occupancy grid of an environment using laser scan data.

My team and I wanted to use opencv to detect specific shapes of obstacles on the map and for that we need to transform the occupancy grid into an image which is being done by the hector_compressed_map_transport ( http://wiki.ros.org/hector_compressed... ).

However, each time we try to run it with the following command:

rosrun hector_compressed_map_transport map_to_image_node

we get the following error:

[rosrun] Couldn't find executable named map_to_image_node below /opt/ros/indigo/share/hector_compressed_map_transport

The hector_slam stack was installed using the following command:

sudo apt-get install ros-indigo-hector-slam

Actually, the only node we have been able to successfully run was the hector_mapping node from the hector_mapping package. All other nodes from any other packages return the same error. However, when using the launch file from the tutorials, the hector_geotiff node does run (but not with rosrun), and we have not been able to successfully modify a launch file to run hector_compressed_map_transport.

Thank you for your time!

edit retag flag offensive close merge delete

Comments

what is the output if you run "roscd hector_compressed_map_transport" and "roscd hector_geotiff"?

DavidN gravatar imageDavidN ( 2016-03-20 04:48:14 -0600 )edit

roscd hector_compressed_map_transport changes the location to /opt/ros/indigo/share/h ector_compressed_map_transport, as expected.

Running the same command on hector_geotiff changes the location to /opt/ros/indigo/share/h ector_compressed_map_transport, again as expected.

tony.hegyes gravatar imagetony.hegyes ( 2016-03-20 18:15:05 -0600 )edit

It's as if the executable just doesn't exist ... I was thinking about compiling the project from source instead of installing it through apt-get, but I thought that I was just doing something wrong maybe ...

tony.hegyes gravatar imagetony.hegyes ( 2016-03-20 18:15:45 -0600 )edit

Unless you have some intention of modifying the source code of the package, it is better to use apt-get to install. Otherwise your workspace size will grow unnecessarily. I tried installation by apt-get for hector_slam and it seemed to work fine. Maybe you could try to remove and re install?

DavidN gravatar imageDavidN ( 2016-03-20 20:37:50 -0600 )edit

I removed and installed it again, but no luck. However, I tried it on a friend's computer and it works perfectly fine. I assume it must be some issue arising from the fact that my ROS is installed in a CHROOT.

I will move my work on a secondary computer where I don't need the CHROOT.

Thanks!

tony.hegyes gravatar imagetony.hegyes ( 2016-03-24 16:41:55 -0600 )edit