Ask Your Question
2

VM RVIZ inits but crashes shortly after start

asked 2016-03-11 11:00:32 -0500

jacksonkr_ gravatar image

updated 2016-03-11 11:01:20 -0500

Notes

  • ROS Indigo / Ubuntu 14.04.5 via VirtualBox 5.0.14 / mbp OS X 10.11.3
  • RVIZ runs rgbdslam with no problems rosrun rgbdslam rgbdslam

Initial Steps

  • $ roscore &
  • $ rosrun using_markers basic_shapes

Error

 $ rosrun rviz rviz
[ INFO] [1457714879.772654975]: rviz version 1.11.10
[ INFO] [1457714879.772826513]: compiled against OGRE version 1.8.1 (Byatis)
libGL error: pci id for fd 23: 80ee:beef, driver (null)
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
libGL error: core dri or dri2 extension not found
libGL error: failed to load driver: vboxvideo
[ INFO] [1457714880.177673412]: Stereo is NOT SUPPORTED
[ INFO] [1457714880.178609213]: OpenGl version: 2.1 (GLSL 1.2).
Segmentation fault (core dumped)

Since RVIZ works on it's own, why am I getting issues with RVIZ running with using_markers ?

edit retag flag offensive close merge delete

Comments

Same problem as well. Ubuntu host with nvidia drivers. Ubuntu 14.04 64 bit guest on Virtual box 5.0.16 and guest additions 5.0.17. How long is VBox going to be blamed for this? We're going on 6 years.

Constantin S gravatar imageConstantin S ( 2016-03-25 13:51:41 -0500 )edit

@Constantin S VirtualBox 5.1.22 r115126 (Qt5.6.2) May 2017 still crashing with 3D acceleration enabled

autonomy gravatar imageautonomy ( 2017-05-23 08:28:58 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2016-08-19 01:29:20 -0500

Shay gravatar image

This is the VirtualBox 3D acceleration for Ubuntu problem. If you turn off the VirtualBox 3D acceleration, the RViz will work fine, but your CPU will be overused, the compiz will take about 70% of your CPU.

I install dual OS in my laptop, then the libGL error is gone. So you may try this.

edit flag offensive delete link more

Comments

I've found that if you users "spheres" in your point clouds that reduces the performance cost by a lot which makes cpu rviz usable for what I'm doing.

jacksonkr_ gravatar imagejacksonkr_ ( 2016-08-19 09:06:08 -0500 )edit

Epic this worked for me

burf2000 gravatar imageburf2000 ( 2017-02-22 02:11:05 -0500 )edit
0

answered 2016-08-18 16:01:30 -0500

ms0719584 gravatar image

Have you checked rviz troubleshooting?

Try run export LIBGL_ALWAYS_SOFTWARE=1 in the same terminal before rosrun using_markers basic_shapes.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-11 11:00:32 -0500

Seen: 1,291 times

Last updated: Aug 19 '16